Vista - immer mehr postgres.exe im Taskmanager

ich habe nochmal
netstat -a -b
ausgeführt:

Proto Lokale Adresse Remoteadresse Status
TCP 0.0.0.0:135 1337-MACHINE:0 ABHÖREN
RpcSs
[svchost.exe]
TCP 0.0.0.0:445 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 0.0.0.0:912 1337-MACHINE:0 ABHÖREN
[vmware-authd.exe]
TCP 0.0.0.0:990 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 0.0.0.0:5000 1337-MACHINE:0 ABHÖREN
[wininit.exe]
TCP 0.0.0.0:5001 1337-MACHINE:0 ABHÖREN
Eventlog
[svchost.exe]
TCP 0.0.0.0:5002 1337-MACHINE:0 ABHÖREN
Schedule
[svchost.exe]
TCP 0.0.0.0:5003 1337-MACHINE:0 ABHÖREN
[lsass.exe]
TCP 0.0.0.0:5004 1337-MACHINE:0 ABHÖREN
[services.exe]
TCP 0.0.0.0:5357 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 0.0.0.0:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP 127.0.0.1:4987 1337-MACHINE:0 ABHÖREN
[firefox.exe]
TCP 127.0.0.1:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP 127.0.0.1:5679 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 127.0.0.1:7438 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 127.0.0.1:50443 1337-MACHINE:50444 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50444 1337-MACHINE:50443 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50445 1337-MACHINE:50446 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50446 1337-MACHINE:50445 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:52018 1337-MACHINE:52019 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52019 1337-MACHINE:52018 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52022 1337-MACHINE:52023 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52023 1337-MACHINE:52022 HERGESTELLT
[firefox.exe]
TCP 192.168.0.1:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 192.168.3.19:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 192.168.3.19:51620 aliot:5222 HERGESTELLT
[infium.exe]
TCP 192.168.3.19:51621 aliot:5222 HERGESTELLT
[infium.exe]
TCP 192.168.3.19:51626 bos-m080b-sdr4:5222 HERGESTELLT
[infium.exe]
TCP 192.168.226.1:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:135 1337-MACHINE:0 ABHÖREN
RpcSs
[svchost.exe]
TCP [::]:445 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:990 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP [::]:5000 1337-MACHINE:0 ABHÖREN
[wininit.exe]
TCP [::]:5001 1337-MACHINE:0 ABHÖREN
Eventlog
[svchost.exe]
TCP [::]:5002 1337-MACHINE:0 ABHÖREN
Schedule
[svchost.exe]
TCP [::]:5003 1337-MACHINE:0 ABHÖREN
[lsass.exe]
TCP [::]:5004 1337-MACHINE:0 ABHÖREN
[services.exe]
TCP [::]:5357 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP [::1]:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP [::1]:5679 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
UDP 0.0.0.0:123 :
W32Time
[svchost.exe]
UDP 0.0.0.0:500 :
[avmike.exe]
UDP 0.0.0.0:3702 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:3702 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:4500 :
[avmike.exe]
UDP 0.0.0.0:5355 :
Dnscache
[svchost.exe]
UDP 0.0.0.0:52107 :
[spoolsv.exe]
UDP 0.0.0.0:56389 :
[avmike.exe]
UDP 0.0.0.0:56390 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:58618 :
[infium.exe]
UDP 127.0.0.1:1900 :
SSDPSRV
[svchost.exe]
UDP 127.0.0.1:44301 :
[PnkBstrA.exe]
UDP 127.0.0.1:54930 :
SSDPSRV
[svchost.exe]
UDP 127.0.0.1:59218 :
BITS
[svchost.exe]
UDP 192.168.0.1:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.0.1:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.0.1:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.0.1:54929 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.19:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.3.19:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.3.19:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.19:54927 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.20:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.20:54926 :
SSDPSRV
[svchost.exe]
UDP 192.168.226.1:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.226.1:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.226.1:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.226.1:54928 :
SSDPSRV
[svchost.exe]
UDP [::]:123 :
W32Time
[svchost.exe]
UDP [::]:500 :
IKEEXT
[svchost.exe]
UDP [::]:3702 :
FDResPub
[svchost.exe]
UDP [::]:3702 :
FDResPub
[svchost.exe]
UDP [::]:5355 :
Dnscache
[svchost.exe]
UDP [::]:56391 :
FDResPub
[svchost.exe]
UDP [::1]:1900 :
SSDPSRV
[svchost.exe]
UDP [::1]:54924 :
SSDPSRV
[svchost.exe]
UDP [::1]:64053 :
[postgres.exe]
UDP [fe80::ffff:ffff:fffe%12]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::ffff:ffff:fffe%12]:54925 :
SSDPSRV
[svchost.exe]
UDP [fe80::4130:cd1c:f21d:e2d3%9]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::4130:cd1c:f21d:e2d3%9]:54921 :
SSDPSRV
[svchost.exe]
UDP [fe80::4829:e568:e148:76cd%18]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::4829:e568:e148:76cd%18]:54922 :
SSDPSRV
[svchost.exe]
UDP [fe80::cd83:f4e7:4e8:2900%11]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::cd83:f4e7:4e8:2900%11]:54920 :
SSDPSRV
[svchost.exe]
UDP [fe80::ed85:e747:444c:4292%20]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::ed85:e747:444c:4292%20]:54923 :
SSDPSRV
[svchost.exe]

hier sind wenigstens einige postgres.exe dabei

netstat -v -a

Proto Lokale Adresse Remoteadresse Status
TCP 0.0.0.0:135 1337-MACHINE:0 ABHÖREN
RpcSs
[svchost.exe]
TCP 0.0.0.0:445 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 0.0.0.0:912 1337-MACHINE:0 ABHÖREN
[vmware-authd.exe]
TCP 0.0.0.0:990 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 0.0.0.0:5000 1337-MACHINE:0 ABHÖREN
[wininit.exe]
TCP 0.0.0.0:5001 1337-MACHINE:0 ABHÖREN
Eventlog
[svchost.exe]
TCP 0.0.0.0:5002 1337-MACHINE:0 ABHÖREN
Schedule
[svchost.exe]
TCP 0.0.0.0:5003 1337-MACHINE:0 ABHÖREN
[lsass.exe]
TCP 0.0.0.0:5004 1337-MACHINE:0 ABHÖREN
[services.exe]
TCP 0.0.0.0:5357 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 0.0.0.0:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP 127.0.0.1:4987 1337-MACHINE:0 ABHÖREN
[firefox.exe]
TCP 127.0.0.1:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP 127.0.0.1:5679 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 127.0.0.1:7438 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP 127.0.0.1:50443 1337-MACHINE:50444 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50444 1337-MACHINE:50443 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50445 1337-MACHINE:50446 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:50446 1337-MACHINE:50445 HERGESTELLT
[thunderbird.exe]
TCP 127.0.0.1:52018 1337-MACHINE:52019 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52019 1337-MACHINE:52018 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52022 1337-MACHINE:52023 HERGESTELLT
[firefox.exe]
TCP 127.0.0.1:52023 1337-MACHINE:52022 HERGESTELLT
[firefox.exe]
TCP 192.168.0.1:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 192.168.3.19:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP 192.168.3.19:51620 aliot:5222 HERGESTELLT
[infium.exe]
TCP 192.168.3.19:51621 aliot:5222 HERGESTELLT
[infium.exe]
TCP 192.168.3.19:51626 bos-m080b-sdr4:5222 HERGESTELLT
[infium.exe]
TCP 192.168.226.1:139 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:135 1337-MACHINE:0 ABHÖREN
RpcSs
[svchost.exe]
TCP [::]:445 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:990 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
TCP [::]:5000 1337-MACHINE:0 ABHÖREN
[wininit.exe]
TCP [::]:5001 1337-MACHINE:0 ABHÖREN
Eventlog
[svchost.exe]
TCP [::]:5002 1337-MACHINE:0 ABHÖREN
Schedule
[svchost.exe]
TCP [::]:5003 1337-MACHINE:0 ABHÖREN
[lsass.exe]
TCP [::]:5004 1337-MACHINE:0 ABHÖREN
[services.exe]
TCP [::]:5357 1337-MACHINE:0 ABHÖREN

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
TCP [::]:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP [::1]:5432 1337-MACHINE:0 ABHÖREN
[postgres.exe]
TCP [::1]:5679 1337-MACHINE:0 ABHÖREN
WcesComm
[svchost.exe]
UDP 0.0.0.0:123 :
W32Time
[svchost.exe]
UDP 0.0.0.0:500 :
[avmike.exe]
UDP 0.0.0.0:3702 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:3702 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:4500 :
[avmike.exe]
UDP 0.0.0.0:5355 :
Dnscache
[svchost.exe]
UDP 0.0.0.0:52107 :
[spoolsv.exe]
UDP 0.0.0.0:56389 :
[avmike.exe]
UDP 0.0.0.0:56390 :
FDResPub
[svchost.exe]
UDP 0.0.0.0:58618 :
[infium.exe]
UDP 127.0.0.1:1900 :
SSDPSRV
[svchost.exe]
UDP 127.0.0.1:44301 :
[PnkBstrA.exe]
UDP 127.0.0.1:54930 :
SSDPSRV
[svchost.exe]
UDP 127.0.0.1:59218 :
BITS
[svchost.exe]
UDP 192.168.0.1:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.0.1:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.0.1:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.0.1:54929 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.19:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.3.19:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.3.19:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.19:54927 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.20:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.3.20:54926 :
SSDPSRV
[svchost.exe]
UDP 192.168.226.1:137 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.226.1:138 :

Es konnten keine Besitzerinformationen ermittelt werden.

x: Fehler bei der Windows Sockets-Initialisierung: 5
UDP 192.168.226.1:1900 :
SSDPSRV
[svchost.exe]
UDP 192.168.226.1:54928 :
SSDPSRV
[svchost.exe]
UDP [::]:123 :
W32Time
[svchost.exe]
UDP [::]:500 :
IKEEXT
[svchost.exe]
UDP [::]:3702 :
FDResPub
[svchost.exe]
UDP [::]:3702 :
FDResPub
[svchost.exe]
UDP [::]:5355 :
Dnscache
[svchost.exe]
UDP [::]:56391 :
FDResPub
[svchost.exe]
UDP [::1]:1900 :
SSDPSRV
[svchost.exe]
UDP [::1]:54924 :
SSDPSRV
[svchost.exe]
UDP [::1]:64053 :
[postgres.exe]
UDP [fe80::ffff:ffff:fffe%12]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::ffff:ffff:fffe%12]:54925 :
SSDPSRV
[svchost.exe]
UDP [fe80::4130:cd1c:f21d:e2d3%9]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::4130:cd1c:f21d:e2d3%9]:54921 :
SSDPSRV
[svchost.exe]
UDP [fe80::4829:e568:e148:76cd%18]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::4829:e568:e148:76cd%18]:54922 :
SSDPSRV
[svchost.exe]
UDP [fe80::cd83:f4e7:4e8:2900%11]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::cd83:f4e7:4e8:2900%11]:54920 :
SSDPSRV
[svchost.exe]
UDP [fe80::ed85:e747:444c:4292%20]:1900 :
SSDPSRV
[svchost.exe]
UDP [fe80::ed85:e747:444c:4292%20]:54923 :
SSDPSRV
[svchost.exe]

… ich habe mein Tool jetzt so umgeschrieben, dass es mit vor die einzelnen PIDs die Anzahl der Prozesse, die postgres.exe heißen hinschreibt.

habe mittlerweile schon 130x postgres.exe
und das bei einer Standart postgreSQL.conf
wo eigentlich nur 100 connections und nen paar superuser_connections reserviert sind ?
trotzdem konnnte ich mich gerade noch mit PGAdminIII auf meinen localhost-Server connecten…

Tons of postgres.exe processes

http://www.scala.com/support/technical-faqs/scala-content-manager-5/why-so-many-instances-of-postgres.exe-listed-in-task-manager

Ich kann leider in den Beiträgen keine Lösung sehen, was willst du damit sagen?

ja tut mir leid,
eine Hilfe ist es wahrscheinlich nicht, aber man kann ja die Erfahrungen der anderen auch mal durchlesen um so vielleicht der lösung ein bisschen näher zu kommen

ok ich habe die lösung sagen wir mal “dreiviertelst” …

ich hab mit dem tool “Process Hacker” herausgefudnen, WIE die ganzen postgres.exe aufgerufen werden.

Erstmal die “normalen” postgres.exe:

“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” -D “C:/Program Files/PostgreSQL/8.4/data”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forklog” “1172” “1168”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkboot” “1108” “-x3”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkboot” “336” “-x4”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkavlauncher” “1108”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkcol” “336”

und jetzt der, der sich andauernd selbst startet:

“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkavworker” “1288”



“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkavworker” “1312”

und so weiter…

wenn ich jetzt noch herausbekomme, wer oder was “forkavworker” ist, wer den aufruft und wer ihn nicht wieder schließt, ist das problem quasi gelöst =)

forkavlauncher - AutoVacuum
forkcol - StatisticCollector

Und damit ist auch meine Vermutung bestätigt, dass dein (Auto-) Vacuum Amok läuft.
Die Anzahl der Worker kannst du in der postgresql.conf festlegen.

Ich hebe meine Hände - ich habe letztes WE PostgreSQL neuinstalliert und habe die Standartsettings wieder angenommen.
Das soll heißen: ich habe den Fehler nicht provoziert/angestoßen. Der muss schon in der anfangs-postgreSQL.conf stehen.

also das große Problem macht ja der forkavworker , welcher wahrscheinlich durch den forkavlauncher gestartet wird…

ich Hinterfrage:

um die vielen postgres.exe wegzubekommen, muss ich folgendes tun:

PGAdmin III starten
mich auf meinen Server connecten
Menüleiste -> Werkzeuge -> Serverkonfiguration -> postgresql.conf

Und die folgenden Einträge so bearbeiten wie ich es hingeschrieben habe:

logging_collector

aktiv
off
Enable capturing of stderr and csvlog

autovacuum

aktiv
off
Enable autovacuum subprocess? ‘on’



bzw. Reicht es wenn man einfach folgende Änderung macht?:

autovacuum_max_workers

aktiv
3
max number of autovacuum subprocesses


stimmt und/oder reicht das so?

Danke und MfG

Ok, es ist gelöst, wenn man autovacuum auf off stellt.
autovacuum

aktiv
off

autovacuum_max_workers

aktiv
3
wird irgendwie ignoriert, es kommen trotzdem immer mehr postgres.exe, wenn man autovacuum nicht off stellt.

MfG

Was auch immer das Problem ist: durch Ausschalten von Autovacuum läufst du über Kurz oder Lang (eher kurz) in heftige Probleme.
Zuerst gibt es Performanceprobleme, weil der Planer unzureichende Pläne generiert. Danach startet Vacuum trotzdem, um die Tabellen zu behandeln.

Ich würde dir also raten, das Problem endgültig zu lösen.

Das was ads schreibt, kann und muss jeder, er ernsthaft mit PG arbeitet, nur unterstreichen!
Du behandelst hier nur Symptome, aber nicht die Ursache. Keiner hier im Foum hat die Lust, in acht Wochen einen Post zum Thema Performance zu beantworten.

Also: Du weißt jetzt, wo du suchen musst… Do it!

Ganz ehrlich: ich wüsste nicht, wo ich danach suchen muss, wen Postgres auf einmal meint 100e von AutoVacuum Prozessen zu starten - vor allem wenn es die Standardkonfiguration ist.

forkavworker ist wahrscheinlich der Worker Prozess, der pro Tabelle gestartet wird. Davon sollten per Default immer 3 parallel laufen.
Stimmt das? Der wird vielleicht oft gestartet, aber mehr als 3 sollten nicht gleichzeitig laufen.

So, was ich aus den ganzen Postings nicht erkennen kann: was genau haben die Prozesse alle in pg_stat_activity stehen?
Stehen die alle auf IDLE oder tun die etwas? Und wenn die IDLE sind, welcher Nutzer hat die Verbindung von wo aufgemacht?

Das Ergebnis von pg_stat_activity steht auf Seite 2:

f;"<IDLE>"
f;"<IDLE>"
f;"<IDLE>"
f;"SELECT waiting, current_query FROM pg_stat_activity;"

Da sind aber die AV-Worker-Prozesse nicht bei…!
Das kann eigentlich nicht richtig sein, die müssten mit “VACUUM irgendwas” als current_query in der Übersicht stehen.

Nur mal so ein Schuss ins Blaue: Kann es sein, dass immer mehr AV-Prozesse gestartet werden, da die sich nicht bei der DB anmelden können…? Indizien sprechen ja dafür: In der pg_stat_activity stehen sie nicht (haben also keine DB-Conn.) und es werden immer mehr. Steht irgendwas im Protokoll oder kannst du mal schauen, ob deine Tabellen von Autovacuum bearbeitet werden/wurden?

Gut, zugegeben weiß ich es ja auch nicht :slight_smile: , aber kein Vacuum ist auch keine Lösung! Evtl. hilft nur Trial and Error…

Vacuum hinterlässt keine IDLE Prozesse. Aber: wenn die Anwendung als Superuser läuft und alle Verbindungen beansprucht, werden dadurch auch die 3 Reserveverbindungen für den Admin (das schließt VACUUM mit ein) blockiert. Dann kann sich VACUUM letztendlich auch nicht mehr zur Datenbank verbinden - demzufolge dürften daher die häufigen Startversuche des avworker herkommen.

Also, die Frage ist: wer macht die IDLE Verbindungen auf - und warum werden die nicht mehr geschlossen?

Noch eine wichtige Frage:

Hast du eine Antivierensoftware (Kaspersky oder so) auf dem Server? Die kann sowas verursachen…

Guten Morgen,

kann das sein:

Es ist ein Vista-spezifiesches Problem,
das hervorgerufen wird,
weil das mit den Rechten nicht so gut in Vista gelöst ist?

In Vista muss man fast jede Applikation über Rechtsklick -> Als Administrator starten… (wenn man dann was mit der Applikation speichern will z.B.)


…ich würde gern mal probieren, was passiert, wenn ich eine neue Verknüpfung anlege, als Ziel

“C:/Program Files/PostgreSQL/8.4/bin/postgres.exe” “–forkavlauncher” "> 1108> "

angebe, und diese Verknüpfung über Rechtsklick -> Als Administrator starten.
Nur weiß ich nicht wofür die fett markierte Zahl steht (die als 2ter Parameter für postgres.exe angegeben wird)?

PS: Ich habe nur AntiVir bei mir installiert und laufen.

MfG

PostgreSQL muss (und sollte) nicht als Administrator laufen. Es nutzt seinen eigenen Benutzeraccount, mehr Rechte sind nicht notwendig.