probleme beim installieren

hallo,

ich hatte mich eigentlich an die schritt-für-schrittanleitung gehalten und bekomme aber beim absetzen des gmake folgend fehlermeldung:

You need to run the ‘configure’ program first. See the file
‘INSTALL’ for installation instructions.
gmake: *** [all] Error 1

interessant ist für mich der letzte teil der fehlermeldung. damit kann ich nicht viel anfangen. ich würde mich über jeden tip freuen.

probiert habe ich auf folgenden systemen:
red hat advanced server 3
suse 9.3
fedora 4
jeweils die gleiche meldung!

hast du ein

./configure

vorher ausgeführt? der meldung nach zu schließen nicht…

hier kannst du das nochmals nachlesen: http://www.postgresql.org/docs/8.1/interactive/installation.html

cu tb.

…deswegen verstehe es ja nicht, weil er mich darauf hinweist dieses kommando auszuführen.

naja hast du das den ausgeführt? ist es sauber durchgeloffen oder hat es eine fehlermeldung gebracht?

cu tb.

ich habe mal die ausgabe von ./configure kopiert:

./configure
checking build system type… i686-pc-linux-gnu
checking host system type… i686-pc-linux-gnu
checking which template to use… linux
checking whether to build with 64-bit integer date/time support… no
checking whether NLS is wanted… no
checking for default port number… 5432
checking for gcc… gcc
checking for C compiler default output… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking if gcc supports -Wdeclaration-after-statement… no
checking if gcc supports -Wold-style-definition… no
checking if gcc supports -Wendif-labels… no
checking if gcc supports -fno-strict-aliasing… yes
configure: using CFLAGS=-O2 -Wall -Wmissing-prototypes -Wpointer-arith -fno-strict-aliasing
checking whether the C compiler still works… yes
checking how to run the C preprocessor… gcc -E
checking allow thread-safe client libraries… no
checking whether to build with Tcl… no
checking whether to build Perl modules… no
checking whether to build Python modules… no
checking whether to build with Kerberos 4 support… no
checking whether to build with Kerberos 5 support… no
checking whether to build with PAM support… no
checking whether to build with Rendezvous support… no
checking whether to build with OpenSSL support… no
configure: using CPPFLAGS=-D_GNU_SOURCE
configure: using LDFLAGS=
checking for gawk… gawk
checking for flex… no
configure: WARNING:
*** Without Flex you will not be able to build PostgreSQL from CVS or
*** change any of the scanner definition files. You can obtain Flex from
*** a GNU mirror site. (If you are using the official distribution of
*** PostgreSQL then you do not need to worry about this because the Flex
*** output is pre-generated.)
checking whether ln -s works… yes
checking for ld used by GCC… /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld… yes
checking for ranlib… ranlib
checking for lorder… no
checking for tar… /bin/tar
checking for strip… strip
checking whether it is possible to strip libraries… yes
checking for bison… no
configure: WARNING:
*** Without Bison you will not be able to build PostgreSQL from CVS or
*** change any of the parser definition files. You can obtain Bison from
*** a GNU mirror site. (If you are using the official distribution of
*** PostgreSQL then you do not need to worry about this because the Bison
*** output is pre-generated.) To use a different yacc program (possible,
*** but not recommended), set the environment variable YACC before running
*** ‘configure’.
checking for perl… /usr/bin/perl
checking for main in -lbsd… yes
checking for setproctitle in -lutil… no
checking for main in -lm… yes
checking for main in -ldl… yes
checking for main in -lnsl… yes
checking for main in -lsocket… no
checking for main in -lipc… no
checking for main in -lIPC… no
checking for main in -llc… no
checking for main in -ldld… no
checking for main in -lld… no
checking for main in -lcompat… no
checking for main in -lBSD… no
checking for main in -lgen… no
checking for main in -lPW… no
checking for main in -lresolv… yes
checking for library containing getopt_long… none required
checking for main in -lunix… no
checking for library containing crypt… -lcrypt
checking for library containing fdatasync… none required
checking for shmget in -lcygipc… no
checking for readline… no
configure: error: readline library not found
If you have readline already installed, see config.log for details on the
failure. It is possible the compiler isn’t looking in the proper directory.
Use --without-readline to disable readline support.

configure: error: readline library not found
If you have readline already installed, see config.log for details on the
failure. It is possible the compiler isn’t looking in the proper directory.
Use --without-readline to disable readline support.

steht doch dort wieso das configure nicht funktioniert hat…

cu tb.

configure: error: readline library not found
If you have readline already installed, see config.log for details on the
failure. It is possible the compiler isn’t looking in the proper directory.
Use --without-readline to disable readline support


laut adminanweisung:
geben sie den befehl ./cofigure ein (sollten sie die libary readline nicht installierthaben, so können sie diese libary auch weglassen. geben sie dazu den befehl ./configure --whitout-readline ein. funktioniert aber auch nicht
:frowning:

naja du musst ja auch

./configure --without-readline

angeben :wink: aber ich vermute mal das ist nur ein tippfehler hier im forum…

bei mir funktioniert der parameter auch. du kannst jedoch vor dem configure mal folgendes eingeben:

make clean

damit löscht du die alten dateien und bereinigst das verzeichnis danach nochmal das ./configure probieren…

cu tb.

/usr/local/src/postgresql-8.0.5]$ make clean
You need to run the ‘configure’ program first. See the file
‘INSTALL’ for installation instructions.
make: *** [clean] Error 1


ich hasse es :evil:

mal ne dumme frage bzw fragen:

  1. wieso installierst du nicht einfach readline. das bräuchst du ja öfters bei programmen die kompliliert werden…

  2. wieso die alte 8.0.5 version?

cu tb.

:smiley:

ok, ich gebe mich geschlagen. jetzt funktionierts. vielen dank! :lol: :lol: :lol:

Hallo Forum,

mein erstes Post und ich hoffe, Ihr könnt mir hier weiterhelfen.
Ich habe das gleiche Problem wie mein Vorredner, konnte es allerdings im Gegensatz zu Ihm nicht lösen.
Ich habe Suse 9.1 und versuche gerade Postgres 8.1.3 zum Laufen zu bringen. Auch bei mir kommt bei ./configure die Meldung, dass readline nicht gefunden wurde.
Also wollte ich den hier gegebenen Rat folgen und readline installieren, wobei ich aber festellen musste, dass es auf der Maschine schon vorhanden ist (in der Version 4.3)
Ist dies die falsche Version, so dass das script sie nicht identifizieren kann? Kann leider die 5er Version von readline nicht installieren, da für Suse 9.1 nicht verfügbar.
Könnte natürlich auch configure mit der Option --without-readline ausführen, habe aber dabei Bauchschmerzen, da ich nicht weiss wozu sie gut ist :frowning:

Also, Euer Rat vor der Tat!
mfg & herzlichen Dank,
Moritz

Ich habe Suse 9.1 und versuche gerade Postgres 8.1.3 zum Laufen zu bringen. Auch bei mir kommt bei ./configure die Meldung, dass readline nicht gefunden wurde.
Also wollte ich den hier gegebenen Rat folgen und readline installieren, wobei ich aber festellen musste, dass es auf der Maschine schon vorhanden ist (in der Version 4.3)

Das Paket heisst libreadline-dev oder ähnlich. Wichtig ist das -dev am Ende, denn dort sind header files etc. drin. Wenn du eh gerade yast offen hast installiere auch zlib-dev oder ähnlich. Das brauchst Du auch, wenn du mit pg_dump komprimierte Dumps erstellen willst.

Könnte natürlich auch configure mit der Option --without-readline ausführen, habe aber dabei Bauchschmerzen, da ich nicht weiss wozu sie gut ist

Siehe http://www.postgresql.org/docs/8.1/interactive/install-procedure.html :

This disables command-line editing and history in psql, so it is not recommended.

psql ist der client mit dem Du über die Konsole auf die Datenbank zugreifst.

Selbst kompilieren macht Spaß, aber ich schließe auf einen nicht so sicheren Kenntnisstand was Linuxsysteme angeht. Installiere daher besser einfach das Paket von suse. Die aktuellsten features von Postgresql brauchst du eh erstmal nicht. Da reicht auch ein 7.4 nach meiner Meinung.