"log_connections = off" wirkt nicht mehr (Debian Upgrade 11 -> 12, Postgres 15 -> 16)

Hallo zusammen,

leider scheint der Parameter “log_connections = off” auf meinem Server keine Wirkung mehr zu haben.
Ich benutze Debain 12 mit Postgres 16 “Debian 16.1-1.pgdg120+1”:
“deb Index of /pub/repos/apt/ bookworm-pgdg main”
Da sich ständig Prozesse in die Datenbank einloggen, wird das Logfile sehr schnell unübersichtlich bzw. extrem groß.

Evtl. ein Bug oder kann man diese Meldungen nicht unterdrücken?
Vor dem Upgrade von Debian von 11 auf 12 und Postgres von 15 auf 16 gab es das Problem noch nicht.

2024-01-08 07:38:18.860 CET xx.xx.xx.xx [unbekannt] [974107-1] [unbekannt]@[unbekannt] LOG: konnte SSL-Verbindung nicht annehmen: no suitable signature algorithm

Die Verbindung wird dann erfolgreich ohne Verschlüsselung aufgebaut, bedauerlicherweise kann ich einige Clients aus historischen Gründen noch nicht auf eine vernünftige SSL-Version upgraden.

Um das offensichtliche auszuschließen: hast Du ein select pg_reload_conf() (oder das Äquivalent via pg_ctl) gemacht, damit die geänderte Einstellung übernommen wird?

Allerdings sieht die Meldung nach einem Problem mit der SSL Konfiguration aus, die solltest Du also mal kontrollieren.

1 „Gefällt mir“

Vielen Dank für die Antwort.
In der Log-Datei, steht jetzt drin:
postgresql-16-main-2024-01-08_053208.log:2024-01-08 07:37:26.902 CET [725177-29] LOG: Parameter »log_connections« auf »on« gesetzt
postgresql-16-main-2024-01-08_053208.log:2024-01-08 07:38:09.432 CET [725177-32] LOG: Parameter »log_connections« auf »off« gesetzt

Dass die SSL-Konfiguration bedingt durch die Client-Seite nicht in Ordnung ist und ein Sicherheitsrisiko darstellt, ist mir klar.
Leider werde ich wohl noch mindestens dieses Jahr damit leben müssen. :frowning: