Installation von PostgreSQL 9.6.12

initdb.exe ist im Unterverzeichnis bin

Bei mir ist da nirgends eine exe.

Egal welches Archiv ich geladen und entpackt habe.

Das ist die ZIP Datei mit den Sourcen.

Du musst die Binaries von dieser Seite laden. Der Link zur ZIP Datei auf der Seite ist: https://sbp.enterprisedb.com/getfile.jsp?fileid=1257551

Der Inhalt sieht dann so aus:

Danke für die ausführliche Beschreibung!

Runtergeladen, entpackt, Datei ausgeführt.

Nichts passiert.

Ich schreibe jetzt den Support an und fertig ist,
egal ob da 9.6.12 oder 11 drauf ist.

Vielen Dank für Deine/Eure Unterstützung!

Gruß
Rolf

Vermutlich fehlen irgendwelche (alten) MSVC DLLs. Die werden normalerweise vom Installer automatisch runtergeladen und installiert.

Hallo zusammen,

kurze Zwischeninfo:
Ich habe die Datenbank lokal gespeichert und lokal gestartet.
ESS Adapter und PostgreSQL 11 auch auf dem Client installiert und eingerichtet.

Und alles funzt ohne Probleme.

Also wenigstens den Fehler etwas eingekreist….

Herzliche Grüße
Rolf

Hallo zusammen,

habe gerade die Antwort von Filemaker bekommen.
Bitte PostgeSQL 9.6.12 installieren.

Ich fasse es nciht.
Jetzt probiere ich irgendwie 9.6.12 zu installieren.

Gruß
Rolf

Da der 9.6 Installer ja ein Problem mit dem Stackbuilder hat(te), versuch doch mal die Installation ohne Stackbuilder:

 postgresql-9.6.24-1-windows-x64.exe  --disable-components stackbuilder

Oder Du packst den Installer einfach nur aus, dann bekommst Du auch das Setup für die VC Runtime:

postgresql-9.6.24-1-windows-x64.exe --mode unattended  --extract-only yes --install_runtimes yes --prefix  postgres-9.6

Damit ist dann alles was Du brauchst im Verzeichnis “postgres-9.6”

Dann musst Du vcredist_x64.exe aus dem installer Unterverzeichnis starten. Möglicherweise auch vcredist2017_x64.exe. Alternativ könntest Du das vcredist*.exe auch über die Microsoft Seiten herunterladen - aber ich weiß nicht welche Version für 9.6 benötigt wird. Also besser die nehmen, die Teil vom Installer sind.

Erst dann wie beschrieben initdb.exe ausführen und via pg_ctl den Windows Service einrichten.

Ganz wichtig: alles als “administrator” machen!

Danke für Deine Antwort!

Ehrlich gesagt: Ich verstehe nur Bahnhof.
Wie meinst Du das mit —disable-components stackbuilder?
Wo bzw. wie mache ich das?

Das mit dem Installer auspacken und dann —mode unattended —extract online yes— sagt mir auch absolut gar nicht.

Gruß
Rolf

Das sind alles Befehle die man auf der Kommandozeile (cmd.exe) ausführt.

Die musst Du so ausführen, wie ich es geschrieben haben. Nicht nur Teile davon.

Der erste Befehl startet den Installer direkt (um Postgres zu installieren) verhindert aber (hoffentlich) die Installation des Stackbuilders (da das wohl zu einem Problem führt).

Die zweite entpackt nur den Inhalt der .exe (die eigentlich eine ZIP Datei ist), so dass Du den Installer für die VCREDIST (“Visual C Runtime Distribution”) direkt als .exe bekommst. Letztendlich hast Du dann die gleichen Dateien als hättest Du die ZIP Datei entpackt - nur halt mit dem Installer für die VCREDIST.

Vielen Dank!

Probiere ich morgen aus und melde mich nochmal.

Gruß
Rolf

Hallo zusammen,

nach den Aussagen in diesem Forum und der Rückmeldung des Actual Adapter konnte ich mir keinen Reim darauf machen warum es mit höheren Versionen nicht funktionieren soll.

Also habe ich mir gedacht, bevor ich 9.6. installiere, lösche alle installierten PostgreSQL Treiber, Adapter und Verbindungen in der Datenbank und setze alles nochmal neu auf.

Glücklicherweise hat das geholfen und das Ganze läuft (bisher) ohne Probleme.

Die Einstellungen sind genau wie vorher (hatte mir Fotos gemacht).

Das ist doch schon kryptisch, oder?

Herzliche Grüße
Rolf