Installation - nichts passiert

Ich versuche, PostgreSQL V. 8.1.3 auf einem W2K-PC zu installieren. Nach Aufruf der Installationsroutine kann ich noch die Setup-Sprache eingeben, danach geschieht nichts mehr. Im Task-Manager findet sich sich 3x msiexec.exe. Im Log-File ist Folgendes zu finden:

=== Logging started: 18.03.2006 22:23:30 ===
MSI © (30:6C): Machine policy value ‘DisableRollback’ is 0
MSI © (30:6C): User policy value ‘DisableRollback’ is 0
MSI © (30:6C): Doing action: INSTALL
Action start 22:23:30: INSTALL.
MSI © (30:6C): UI Sequence table ‘InstallUISequence’ is present and populated.
MSI © (30:6C): Running UISequence
MSI © (30:6C): Doing action: AppSearch
Action start 22:23:30: AppSearch.
MSI © (30:6C): Note: 1: 2205 2: 3: AppSearch
MSI © (30:6C): Note: 1: 2228 2: 3: AppSearch 4: SELECT Property, Signature_ FROM AppSearch
Action ended 22:23:30: AppSearch. Return value 0.
MSI © (30:6C): Doing action: LaunchConditions
Action start 22:23:30: LaunchConditions.
Action ended 22:23:30: LaunchConditions. Return value 1.
MSI © (30:6C): Doing action: GetAvailableLocales
Action start 22:23:30: GetAvailableLocales.
MSI © (30:6C): Creating MSIHANDLE (1) of type 790542 for thread 620
DEBUG: Error 2769: Custom Action GetAvailableLocales did not close 1 MSIHANDLEs.
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2769. The arguments are: GetAvailableLocales, 1,
Action ended 22:23:32: GetAvailableLocales. Return value 1.
MSI © (30:6C): Doing action: CheckAvailableDLLs
Action start 22:23:32: CheckAvailableDLLs.
MSI © (30:6C): Creating MSIHANDLE (92) of type 790542 for thread 620

Kann das jemand deuten?

Vielen Dank im Voraus.
Rob’

hi,

das problem kommt immer wieder mal vor und ist auch in den mailinglisten dokumentiert. z.b. hier: http://archives.postgresql.org/pgsql-bugs/2006-02/msg00175.php

an sich wird jedes mal auf die windows faq, abschnitt 3.1 verwiesen: http://www.postgresql.org/docs/faqs.FAQ_windows.html#3.1

vielleicht hilft dir das weiter…

cu tb.

Danke für Deine Antwort. Den FAQ-Artikel hatte ich gefunden. Allerdings verwende ich keine der genannten Antiviren-Software. Aber ich werde es trotzdem mal probieren.

Rob’

Hallo Rob’,

An dieser Stelle tritt der Fehler auf. MSI überprüft hier die vordefinierten Bedingungen, die für die Installation gegeben sein müssen. Offensichtlich sind sie bei Dir nicht vorhanden.

Erfolgte die Installation unter einem User mit :!: vollen :!: Admin-Rechten?






mfg

fristo

Hi,

Administratorrechte sind vorhanden. Auch das Deaktivieren meines Virenscanners (Antivir) brachte keinen Erfolg.

Was besagt denn folgende Meldung:
DEBUG: Error 2769: Custom Action GetAvailableLocales did not close 1 MSIHANDLEs.
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2769. The arguments are: GetAvailableLocales, 1,

Danke für weitere Hinweise.

Rob’

Hallo Rob’,

hier eine Beschreibung für die Ursache und deren Beseitigung:

That is not the problem. The MSIHANDLE problem is a known issue, but it doesn’t really matter. > The problem is the crashing in CheckAvailableDLLs > - you’ll notice in the log it never returns from there.

The first thing I’d check is if you have Cygwin installed on your system. The installer tries to detect this, but it may fail at that. Cygwin is known to cause crashes with it’s > tcl and/or python DLLs> .

If this is not the case, look for any > python, perl or tcl DLLs > in either your system directories or in directories in your path. Try moving/renaming them and restarting the installer.

If this also is not the case, look for non-standard > openssl DLLs (libeay32.dll) > in system dirs or path that may be causing a crash.

Noch ein anderes Zitat:

I don’t have Cygwin. Based on your input I searched directories of all directories in my path. I found that a GCC based compiler called WinAVR that I installed recently comes with some TCL DLLs(and a Cygwin exe file). Anyway, renaming the WinAVR directory fixed the pgsql installation problem.

Original: http://www.mail-archive.com/pgsql-admin@postgresql.org/msg17506.html
Original: http://www.mail-archive.com/pgsql-admin@postgresql.org/msg17508.html



mfg

fristo

Hallo fristo,

WinAVR, da wäre ich nie drauf gekommen. Verzeichnis umbenannt, und alles geht. :lol:

Danke.

Rob’

Hallo Rob’,

nach Abschluss der Installation kannst Du die Unbenennung der Verzeichnisse wieder rückgängig machen.


mfg

fristo

Hab’ ich schon gemacht.

Danke.

Rob’