ODBC Problem

Alle Fragen und Probleme zu den externen Schnittstellen wie ODBC, JDBC, ...
kiwi
Neuer Benutzer
Beiträge: 4
Registriert: Di 28. Jul 2009, 11:23

Beitrag von kiwi » Mo 3. Aug 2009, 14:23

hallo zusammen!

ich habe ein sehr ähnliches problem, wie oben genannt.

mein ziel ist es, von excel eine verbindung zu einer postgres datenbank herzustellen.

nur bekommich das einfach nicht hin :confused:

ich habe bereits versucht über den "externe daten importieren"-assistenten daten auszulesen, habe alle dazu nötigen sachen installiert und eingerichtet, nur bekomme ich da die fehlermeldung "Es konnten keine Tabellenlisten von der Datenquelle bezogen werden."

weiters habe ich es direkt über vba probiert, hierzu der aktuelle code:

Dim dbOut As ADODB.Connection
Dim rsOut As ADODB.Recordset
Dim connectionstring As String

Set dbOut = New ADODB.Connection
Set rsOut = New ADODB.Recordset
Dim cmd As New ADODB.Command

connectionstring = "Driver={PostgreSQL};" & _
"Data Source=127.0.0.1;" & _
"Port=5432;" & _
"location= dbname;" & _
"User ID=uname;" & _
"password=pw;"

dbOut.connectionstring = connectionstring

dbOut.Open

hier bekomme ich die obige fehlermeldung: Der Datenquellenname wurde nicht gefunden und es wurde kein Standardtreiber angegeben.

ich habe bereits etliche odbc und ole db treiber herunter geladen und installiert und alle möglichen einstellungen ausprobiert, aber nichts funktioniert :confused:

ich hoffe es kann mir jemand sagen was ich falsch mache, oder was ich übersehen hab!!!

viele dank schon mal im voraus!

lg

ads
Erfahrener Benutzer
Beiträge: 4148
Registriert: Mi 8. Feb 2006, 10:58
Wohnort: MD
Kontaktdaten:

Beitrag von ads » Mo 3. Aug 2009, 14:33

kiwi hat geschrieben:hier bekomme ich die obige fehlermeldung: Der Datenquellenname wurde nicht gefunden und es wurde kein Standardtreiber angegeben.

Nun, das deutet aber arg auf einen Fehler in deinen Angaben hin. Ich glaube nicht, dass da überhaupt schon eine Verbindung aufgemacht wird, weil einfach noch wichtige Daten fehlen.

Gibt es denn in der Dokumentation ein Beispiel, wie so ein Verbindungsaufbau auszusehen hat?



ich habe bereits etliche odbc und ole db treiber herunter geladen und installiert und alle möglichen einstellungen ausprobiert, aber nichts funktioniert :confused:
Oh, wusste gar nicht, dass es so viele davon gibt.
Egal, wenn die alle nicht funktionieren, liegt das Problem wohl wirklich - wie oben beschrieben - an fehlerhaften Angaben.
Xandrian: Kurz gesagt: Du hast ein falsches Konzept und willst nicht auf ads hören Bild

Jetzt NEU: PostgreSQL - Datenbankpraxis für Anwender, Administratoren und Entwickler

PostgreSQL Service & Support

kiwi
Neuer Benutzer
Beiträge: 4
Registriert: Di 28. Jul 2009, 11:23

Beitrag von kiwi » Mo 3. Aug 2009, 14:42

kann gut sein, dass die Angaben falsch sind.
ich habe es uA nach dieser dokumentation gemacht
http://port25.technet.com/videos/research/excelopendbprimer.pdf
aber wenn es wirklich daran liegt, dann weis ich nicht welche falsch sind, bzw fehlen... habe eigentlich alles so gemacht wie bei ähnlichen beispielen.

vielleicht eine ahnung?

akretschmer
Erfahrener Benutzer
Beiträge: 7677
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Beitrag von akretschmer » Mo 3. Aug 2009, 14:49

kiwi hat geschrieben:kann gut sein, dass die Angaben falsch sind.
ich habe es uA nach dieser dokumentation gemacht
http://port25.technet.com/videos/research/excelopendbprimer.pdf
aber wenn es wirklich daran liegt, dann weis ich nicht welche falsch sind, bzw fehlen... habe eigentlich alles so gemacht wie bei ähnlichen beispielen.

vielleicht eine ahnung?


Läuft denn die DB überhaupt und kannst Du Dich mit psql drauf connecten?

Andreas
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

kiwi
Neuer Benutzer
Beiträge: 4
Registriert: Di 28. Jul 2009, 11:23

Beitrag von kiwi » Mo 3. Aug 2009, 14:51

habe sie mittels pgadmin angelegt, da funktioniert alles einwandfrei =)

ads
Erfahrener Benutzer
Beiträge: 4148
Registriert: Mi 8. Feb 2006, 10:58
Wohnort: MD
Kontaktdaten:

Beitrag von ads » Mo 3. Aug 2009, 15:52

Der Link ist alles, aber kein PDF ...
Xandrian: Kurz gesagt: Du hast ein falsches Konzept und willst nicht auf ads hören Bild

Jetzt NEU: PostgreSQL - Datenbankpraxis für Anwender, Administratoren und Entwickler

PostgreSQL Service & Support

kiwi
Neuer Benutzer
Beiträge: 4
Registriert: Di 28. Jul 2009, 11:23

Beitrag von kiwi » Mo 3. Aug 2009, 16:46

hmm...

ich werd mir die angaben nochmal genau vorknöpfen, hoffentlich gehts dann =)

vielen dank jedenfalls für den tip

Antworten