Probleme mit Zeichensatz

Probleme, Fragen die mit der Installation und Anwendung der PostGIS-Erweiterung zu tun haben.
Antworten
Gisman
Erfahrener Benutzer
Beiträge: 1140
Registriert: Fr 20. Jan 2006, 15:30
Wohnort: Pfalz
Kontaktdaten:

Probleme mit Zeichensatz

Beitrag von Gisman » Fr 5. Mai 2006, 15:06

Hallo!
Ich möchte aus einem Shapefile über shp2pgsql ein SQL-Statement machen und dieses dann in Die DB importieren. funktioniert auch alles soweit ganz gut, bis irgendwo ein Umlaut auftaucht(sind Ortsnamen), dann wird die Transaktion abgebrochen.
Im SQL- Statemant steht so ein Kraut-und-Rüben-Ding für den Umlaut. Die DB ist UTF-8 codiert. Was muß ich ich da wo drehen das das geht. Das ging schon mal einfach so auf einem anderen Server, also hab ich da an nix böses gedacht...

Danke und SW ;)
Uwe
-------------------------------
Suse 10.0, PG 8.1.3, pGIS 1.1.2
Have a lot of fun!

fristo
Erfahrener Benutzer
Beiträge: 670
Registriert: Do 8. Dez 2005, 12:30
Wohnort: Raum Frankfurt/Main

Beitrag von fristo » Fr 5. Mai 2006, 16:24

Hallo Uwe,

ich hatte ein ähnliches Problem unter Windows, da PgAdmin immer UNICODE verlangt, um alle Zeichen darzustellen. Mir hat folgende Lösung geholfen:

Code: Alles auswählen

SET client_encoding TO 'latin1';

Copy ...
From ...
...

SET client_encoding TO 'UNICODE';


Ich weiß aber nicht ob das auch unter Linux so funktioniert.



mfg

fristo

Gisman
Erfahrener Benutzer
Beiträge: 1140
Registriert: Fr 20. Jan 2006, 15:30
Wohnort: Pfalz
Kontaktdaten:

Beitrag von Gisman » Fr 5. Mai 2006, 17:31

Jo, danke, werd ich gleich heut abend mal testen.

Grüssle Uwe
Have a lot of fun!

fristo
Erfahrener Benutzer
Beiträge: 670
Registriert: Do 8. Dez 2005, 12:30
Wohnort: Raum Frankfurt/Main

Beitrag von fristo » Sa 6. Mai 2006, 01:40

Mal nachgefragt: Warum verwendest Du für die Datenbank UTF-8?


mfg

fristo

Gisman
Erfahrener Benutzer
Beiträge: 1140
Registriert: Fr 20. Jan 2006, 15:30
Wohnort: Pfalz
Kontaktdaten:

Beitrag von Gisman » Mo 8. Mai 2006, 10:44

fristo hat geschrieben:Mal nachgefragt: Warum verwendest Du für die Datenbank UTF-8?


mfg

fristo


Ehrlich gesagt, hab ich (noch) nicht darüber nachgedacht. :o ops:

Bisher haben die Default-Werte funktioniert, und es ist das erste Mal das ich ein Umlautproblem habe...
Ich kann zwar ziemlich gut mit Geodaten, PostGIS und 3D-Modellen, bin aber auf dieser Ebene noch am Üben sozusagen :wink:

Gruß Uwe

EDIT:
Folgende Lösungen können vorgenommen werden:
- die von fristo beschriebene
- in der postgresql.conf kann das client_encoding ebenfalls eingestellt werden
- der PostGIS-Loader shp2pgsql bietet über die _W-Option ebenfalls eine Möglichkeit das encoding einzustellen. In meiner ausgedruckten Anleitung war das nicht beschrieben sondern nur mit shp2pgsql --help, deswegen hab ich es wohl auch nicht gesehen :o ops:

CU Uwe
Have a lot of fun!

fristo
Erfahrener Benutzer
Beiträge: 670
Registriert: Do 8. Dez 2005, 12:30
Wohnort: Raum Frankfurt/Main

Beitrag von fristo » Mo 8. Mai 2006, 11:12

Hallo Uwe,

das mit dem UTF-8 Zeichensatz für den Server ist richtig. Ich habe mich da irritieren lassen. Dein Problem ist/war die Client-Encoding, und die ist vom eingestellten Zeichensatz des Betriebssystems abhängig.



mfg

fristo

Antworten