ssl via psql

Alle Fragen und Probleme zu den externen Schnittstellen wie ODBC, JDBC, ...
beho
Benutzer
Beiträge: 64
Registriert: Di 24. Okt 2006, 11:49
Wohnort: Erfurt

ssl via psql

Beitrag von beho » Do 26. Feb 2009, 12:01

Hallo,

ich versuche grad eine psql Verbindung aufzubauen, die ssl verwendet, da der Server nur ssl Verbindungen zulässt. Ich seh allerdings nicht, was ich angeben/tun muss. Mit "sslmode=require" willer nicht.

Die Frage erweitert sich dann, wenn ich einen Dump der DB ziehen muss. SSL-Schalter für pg_dump bzw. pg_dumpall??

Grüße und Dank im Voraus
beho

ads
Erfahrener Benutzer
Beiträge: 4148
Registriert: Mi 8. Feb 2006, 10:58
Wohnort: MD
Kontaktdaten:

Beitrag von ads » Do 26. Feb 2009, 12:15

beho hat geschrieben:Mit "sslmode=require" willer nicht.

Das ist keine qualifizierende Fehlermeldung, mit der dir irgendjemand weiterhelfen kann.
Xandrian: Kurz gesagt: Du hast ein falsches Konzept und willst nicht auf ads hören Bild

Jetzt NEU: PostgreSQL - Datenbankpraxis für Anwender, Administratoren und Entwickler

PostgreSQL Service & Support

akretschmer
Erfahrener Benutzer
Beiträge: 7645
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Beitrag von akretschmer » Do 26. Feb 2009, 12:23

beho hat geschrieben:Hallo,

ich versuche grad eine psql Verbindung aufzubauen, die ssl verwendet, da der Server nur ssl Verbindungen zulässt. Ich seh allerdings nicht, was ich angeben/tun muss. Mit "sslmode=require" willer nicht.

Die Frage erweitert sich dann, wenn ich einen Dump der DB ziehen muss. SSL-Schalter für pg_dump bzw. pg_dumpall??

Grüße und Dank im Voraus
beho


Code: Alles auswählen

elcome to psql 8.3.6 (server 8.3.5), the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

SSL connection (cipher: DHE-RSA-AES256-SHA, bits: 256)



Ich erkenne kein Problem, erst recht nicht Deines.

Andreas, jetzt den Server mal updaten gehend...
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

beho
Benutzer
Beiträge: 64
Registriert: Di 24. Okt 2006, 11:49
Wohnort: Erfurt

Beitrag von beho » Do 26. Feb 2009, 15:02

Hallo nochmal,

@ads sry für meine unpräzision:
meine Eingabe: psql [*] -h host [*] db [*] username
[*] : an diesen Stellen habe ich in unterschiedlichen Versuchen sslmode= required reingschrieben.
und als Fehler zurückbekommen:
"psql: FATAL: kein pg_hba.conf-Eintrag für Host 'ip', Benutzer 'username', Datenbank 'db', SSL aus

@akretschmer ok, ich sehe du hast eine ssl Verbindung. ich versteh nur leider offenbar nicht wie du sie etablierst. Ich seh auch keinen Parameter den ich angeben könnt.

Grüße
beho

ads
Erfahrener Benutzer
Beiträge: 4148
Registriert: Mi 8. Feb 2006, 10:58
Wohnort: MD
Kontaktdaten:

Beitrag von ads » Do 26. Feb 2009, 15:28

beho hat geschrieben:"psql: FATAL: kein pg_hba.conf-Eintrag für Host 'ip', Benutzer 'username', Datenbank 'db', SSL aus

Was passiert wohl, wenn du die Fehlermeldung in Google wirfst?

*klick mich*
Xandrian: Kurz gesagt: Du hast ein falsches Konzept und willst nicht auf ads hören Bild

Jetzt NEU: PostgreSQL - Datenbankpraxis für Anwender, Administratoren und Entwickler

PostgreSQL Service & Support

akretschmer
Erfahrener Benutzer
Beiträge: 7645
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Beitrag von akretschmer » Do 26. Feb 2009, 15:37

beho hat geschrieben:Hallo nochmal,

@ads sry für meine unpräzision:
meine Eingabe: psql [*] -h host [*] db [*] username
[*] : an diesen Stellen habe ich in unterschiedlichen Versuchen sslmode= required reingschrieben.
und als Fehler zurückbekommen:
"psql: FATAL: kein pg_hba.conf-Eintrag für Host 'ip', Benutzer 'username', Datenbank 'db', SSL aus

@akretschmer ok, ich sehe du hast eine ssl Verbindung. ich versteh nur leider offenbar nicht wie du sie etablierst. Ich seh auch keinen Parameter den ich angeben könnt.

Grüße
beho



Zitat aus Deinem ersten Beitrag:

Code: Alles auswählen

ich versuche grad eine psql Verbindung aufzubauen, die ssl verwendet, da der Server nur ssl Verbindungen zulässt.


Exakt das habe ich auch getan, mit hostssl in der pg_hba.conf. IIRC erzwinge ich damit SSL, psql hat aber auch ohne hostssl, nur mit host, eine SSL-Verbindung aufgebaut, scheinbar ist das Default. (ich hab da noch nie drüber nachgedacht...=.

Jedenfalls, nach Deinem Posting erzwingt der Server SSL. Auf Client-Seite ist da nix mehr zu machen.

Also, bau einfach mal eine Verbindung auf und schaue, was passiert. Ohne das sslmode - Dingens. Oder willst Du erzwingen, daß der Client ein Certificat hat?
Die Doku enthält übrigens dazu ein eigenes Kapitel.

Andreas
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

akretschmer
Erfahrener Benutzer
Beiträge: 7645
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Beitrag von akretschmer » Do 26. Feb 2009, 15:40

akretschmer hat geschrieben:

Code: Alles auswählen

elcome to psql 8.3.6 (server 8.3.5), the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

SSL connection (cipher: DHE-RSA-AES256-SHA, bits: 256)



Ich erkenne kein Problem, erst recht nicht Deines.

Andreas, jetzt den Server mal updaten gehend...




Sorry, Copy&Paste - Error

Code: Alles auswählen

kretschmer@tux:~$ psql -U kretschmer -h apache test
Password for user kretschmer:
Welcome to psql 8.3.6, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit

SSL connection (cipher: DHE-RSA-AES256-SHA, bits: 256)


Andreas, dafür nun mit aktueller Version...
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

beho
Benutzer
Beiträge: 64
Registriert: Di 24. Okt 2006, 11:49
Wohnort: Erfurt

Beitrag von beho » Do 26. Feb 2009, 16:44

Jedenfalls, nach Deinem Posting erzwingt der Server SSL.

genau.

Auf Client-Seite ist da nix mehr zu machen.
Also, bau einfach mal eine Verbindung auf und schaue, was passiert.

selber Fehler:

Code: Alles auswählen

psql: FATAL: kein pg_hba.conf-Eintrag für Host 'ip', Benutzer 'username', Datenbank 'db', SSL aus


Ohne das sslmode - Dingens. Oder willst Du erzwingen, daß der Client ein Certificat hat?

nein.

Die Doku enthält übrigens dazu ein eigenes Kapitel.

wenn ich mit der weiterkäme würd ich doch nicht fragen ;)

akretschmer
Erfahrener Benutzer
Beiträge: 7645
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Beitrag von akretschmer » Do 26. Feb 2009, 17:16

beho hat geschrieben:genau.


selber Fehler:

Code: Alles auswählen

psql: FATAL: kein pg_hba.conf-Eintrag für Host 'ip', Benutzer 'username', Datenbank 'db', SSL aus





Ist der Client mit SSL-Unterstützung gebaut?

Andreas
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

ads
Erfahrener Benutzer
Beiträge: 4148
Registriert: Mi 8. Feb 2006, 10:58
Wohnort: MD
Kontaktdaten:

Beitrag von ads » Do 26. Feb 2009, 18:43

In der psql Manpage steht ein alternativer Weg, wie du SSL auf der Clientseite erzwingen kannst. Ansonsten: ist auf dem System SSL vorhanden? Kennt der Server auch SSL, wenn du das schon verlangst?

Wie sieht dein pg_hba.conf Eintrag aus?
Xandrian: Kurz gesagt: Du hast ein falsches Konzept und willst nicht auf ads hören Bild

Jetzt NEU: PostgreSQL - Datenbankpraxis für Anwender, Administratoren und Entwickler

PostgreSQL Service & Support

Antworten