psql.exe mit Option '-E' starten, verlangt ein Passwort des 'Administrators'

Fragen und Probleme zu Verwaltungstools.
phppgadmin und pgadmin bitte in die entsprechenden Foren!
Antworten
vegochilde
Neuer Benutzer
Beiträge: 6
Registriert: Do 21. Jun 2012, 13:50

psql.exe mit Option '-E' starten, verlangt ein Passwort des 'Administrators'

Beitrag von vegochilde » Do 28. Jun 2012, 12:38

Win 7
PostgreSQL 9.1 mit PostGIS 2.0
PostgreSQL-Anfaenger


Liebe PostgreSQL-Gemeinde,

soweit ich das bei Momjian (PostgreSQL. Introduction and Concepts, 2000: 247) verstanden habe, zeigt die E-Option (psql.exe -E) die (im Hintergrund laufende) Syntax der in die psql-Konsole eingegebenen Befehle.

Wenn ich nun in der Konsole des Betriebssystems (cmd.exe) psql.exe -E ausfuehre, wird das Passwort des Benutzers 'Administrator' verlangt. Diese Rolle wird in pgAdmin III nicht angezeigt und wurde von mir auch nie erstellt. Die Eingabe aller Passwörter meiner Rollen werden mit der Fehlermeldung

"
psql FATAL: Passwort-Authentifizierung für Benutzer >>Administrator<< fehlgeschlagen"

quittiert.


Habt Ihr Ideen, wie ich die Option dennoch aufrufen könnte?

Anmerkung: Ich hatte die bei der Installation angelegte Rolle 'postgres' mit einem neuen Namen versehen (weil auch eine Datenbank standardmaessig 'postgres' heisst, und ich vor allem bei der Anzeige der Zugriffsrechte durch den Tuedel kam.). Danach konnte ich mich über den pdgAdmin III über diese Rolle (diese wurde verlangt) logischerweise nicht mehr mit dem Server verbinden. Nachdem ich die unbenannte Rolle über die psql-Konsole wieder mit dem alten Namen 'postgres' und einem neuen Passwort versehen hatte, gelang die Verbindung zum Server wieder.

LG
vegochilde


Antworten