Problem bei Kopieren von Archive-Logs

Konfiguration des PostgreSQL Datenbankservers.
Antworten
sensej_ju
Neuer Benutzer
Beiträge: 15
Registriert: Fr 20. Sep 2013, 10:43

Problem bei Kopieren von Archive-Logs

Beitrag von sensej_ju »

Hallo!
Habe ein kleines Problem beim Kopieren der Archive-Logs.
Habe einen Master(192.168.1.10), der in der Domäne ist und einen Slave(192.168.1.20) lokal/nicht in der Domäne.
Den Slave kann ich leider nicht in die Domäne aufnehmen.
Auf dem Slave habe ich ein neues Verzeichnis C:\Postgres\Archive angelegt und mit allen Rechten frei gegeben.
Die Dateien vom Master sollen auf dem Slave in diesem Verzeichnis abgelegt werden.
Auf die Slavefreigabe kann ich durch die Angabe von Benutzerdaten mit Windows-Explorer zugreifen.

Auf dem Master habe ich folgendes konfiguriert und ihn neu gestartet.
archive_command = 'copy "%p" "\\\\192.168.1.20\\Postgres\\Archive\\%f"'

Hier ist die erste Fehlermeldung.

Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsches Kennwort.
2013-09-25 09:32:44 CEST LOG: Archivbefehl ist fehlgeschlagen mit Statuscode 1
2013-09-25 09:32:44 CEST DETAIL: Der fehlgeschlagene Archivbefehl war: copy "pg_xlog\00000002000000000000003D" \\192.168.1.20\Postgres\Archive\00000002000000000000003D


Der Test diese Datei manuell über Eingabeaufforderung zu kopieren war erfolgreich: copy "C:\Program Files\PostgreSQL\9.3\data\pg_xlog\000000020000000000000046" \\192.168.1.20\Postgres\Archive\000000020000000000000046

Dann habe ich mit net use H: \\192.168.1.20\Postgres\Archive /u:Freigabe meinPasswort
ein H-Laufwerk gemappt, Parameter archive_command = 'copy "%p" "H:\\%f"' geändert und den Master neu gestartet.

Hier ist die nächste Fehlermeldung. :(

Das System kann den angegebenen Pfad nicht finden.
2013-09-25 13:19:40 CEST LOG: Archivbefehl ist fehlgeschlagen mit Statuscode 1
2013-09-25 13:19:40 CEST DETAIL: Der fehlgeschlagene Archivbefehl war: copy "pg_xlog\000000020000000000000046" H:\000000020000000000000046


Das Kopieren dieser Datei mit copy über Eingabeaufforderung hat wieder problemlos funktioniert: copy "C:\Program Files\PostgreSQL\9.3\data\pg_xlog\000000020000000000000046" H:\\000000020000000000000046


Wieso funktioniert das Kopieren über die Eingabeaufforderung und unter PostgreSQL nicht ????
Gibt es andere Alternativen für dieses Szenario??

sensej_ju
Neuer Benutzer
Beiträge: 15
Registriert: Fr 20. Sep 2013, 10:43

Re: Problem bei Kopieren von Archive-Logs

Beitrag von sensej_ju »

Sorry,
kleiner Schreibfehler

Dann habe ich mit net use H: \\192.168.1.20\Postgres\Archive /u:MeinBenutzer meinPasswort

sensej_ju
Neuer Benutzer
Beiträge: 15
Registriert: Fr 20. Sep 2013, 10:43

Re: Problem beim Kopieren von Archive-Logs

Beitrag von sensej_ju »

sensej_ju hat geschrieben:Hallo!
Habe ein kleines Problem beim Kopieren der Archive-Logs.
Habe einen Master(192.168.1.10), der in der Domäne ist und einen Slave(192.168.1.20) lokal/nicht in der Domäne.
Den Slave kann ich leider nicht in die Domäne aufnehmen.
Auf dem Slave habe ich ein neues Verzeichnis C:\Postgres\Archive angelegt und mit allen Rechten frei gegeben.
Die Dateien vom Master sollen auf dem Slave in diesem Verzeichnis abgelegt werden.
Auf die Slavefreigabe kann ich durch die Angabe von Benutzerdaten mit Windows-Explorer zugreifen.

Auf dem Master habe ich folgendes konfiguriert und ihn neu gestartet.
archive_command = 'copy "%p" "\\\\192.168.1.20\\Postgres\\Archive\\%f"'

Hier ist die erste Fehlermeldung.

Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsches Kennwort.
2013-09-25 09:32:44 CEST LOG: Archivbefehl ist fehlgeschlagen mit Statuscode 1
2013-09-25 09:32:44 CEST DETAIL: Der fehlgeschlagene Archivbefehl war: copy "pg_xlog\00000002000000000000003D" \\192.168.1.20\Postgres\Archive\00000002000000000000003D


Der Test diese Datei manuell über Eingabeaufforderung zu kopieren war erfolgreich: copy "C:\Program Files\PostgreSQL\9.3\data\pg_xlog\000000020000000000000046" \\192.168.1.20\Postgres\Archive\000000020000000000000046

Dann habe ich mit net use H: \\192.168.1.20\Postgres\Archive /u:Freigabe meinPasswort
ein H-Laufwerk gemappt, Parameter archive_command = 'copy "%p" "H:\\%f"' geändert und den Master neu gestartet.

Hier ist die nächste Fehlermeldung. :(

Das System kann den angegebenen Pfad nicht finden.
2013-09-25 13:19:40 CEST LOG: Archivbefehl ist fehlgeschlagen mit Statuscode 1
2013-09-25 13:19:40 CEST DETAIL: Der fehlgeschlagene Archivbefehl war: copy "pg_xlog\000000020000000000000046" H:\000000020000000000000046


Das Kopieren dieser Datei mit copy über Eingabeaufforderung hat wieder problemlos funktioniert: copy "C:\Program Files\PostgreSQL\9.3\data\pg_xlog\000000020000000000000046" H:\\000000020000000000000046


Wieso funktioniert das Kopieren über die Eingabeaufforderung und unter PostgreSQL nicht ????
Gibt es andere Alternativen für dieses Szenario??

akretschmer
Erfahrener Benutzer
Beiträge: 7733
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Re: Problem beim Kopieren von Archive-Logs

Beitrag von akretschmer »

sensej_ju hat geschrieben:
sensej_ju hat geschrieben:
Wieso funktioniert das Kopieren über die Eingabeaufforderung und unter PostgreSQL nicht ????


Könnte an Rechteproblemen liegen. Aber ich nix Windows.

Gibt es andere Alternativen für dieses Szenario??


Linux.

skrejci
Neuer Benutzer
Beiträge: 5
Registriert: So 8. Dez 2013, 18:44

Re: Problem bei Kopieren von Archive-Logs

Beitrag von skrejci »

N'Abend!

Ich nehm nicht an, dass dieser Thread noch aktiv ist, oder? Ich hätt nämlich dasselbe Problem...

Soll für einen Kunden, der PostgreSQL auf Windows Server 2008 R2 betreibt, eine Replikation einrichten. Jetzt teste ich mit zwei Virutal Boxen, und komm über das Problem leider nicht drüber. Gibt's Ideen außer auf Linux umzusteigen?

Danke, Stefan

skrejci
Neuer Benutzer
Beiträge: 5
Registriert: So 8. Dez 2013, 18:44

Re: Problem bei Kopieren von Archive-Logs

Beitrag von skrejci »


Antworten