PostgreSQL 8.4 auf Debian Wheezy

Fragen und Probleme zur Installation von PostgreSQL (hauptsächlich Binary Packete).
Antworten
jogi29
Neuer Benutzer
Beiträge: 4
Registriert: Di 2. Dez 2014, 09:26
Wohnort: Ländle

PostgreSQL 8.4 auf Debian Wheezy

Beitrag von jogi29 » Di 2. Dez 2014, 10:25

Hallo,

ich habe das 1. Mal mit PostgreSQL zu tun, also keine Ahnung.
Ich habe einen Fileserver mit Debian Wheezy, das System liegt auf einer SSD, die Daten auf einem Raid 5 bestehend aus 4x 3TB HDDs. Die Client-PCs haben Win 8.1.
Die Samba-Freigaben auf dem Raid 5 funktionieren schon seit längerem.

Da ich meine Software wechseln muss (Softwarefirma stellt die Software zum 31.12.2014 ein) muss ich einen Softwarewechsel durchführen und die neue Software benötigt auf dem Server einen PostgreSQL 8.4, neuere Versionen werden nicht unterstützt. Ich habe nun die Pakete 8.4.21 aus Squeeze installiert, was auch funktioniert hat.

In der neuen Win-Software muss ich die IP sowie den Port des PostgreSQL eintragen, damit eine Verbindung hergestellt wird.
1. Problem:
Ich muss das Passtwort des Benutzers "postgres" erst nochmals setzen, bevor eine Verbindung zustande kommt, dann klappt es aber und bei Neustart des Clients ist die Verbindung auch weiter vorhanden. Sollte eigentlich nicht weiter stören, da die Verbindung 1x hergestellt wird und danach nichts mehr geändert wird.
2. Problem:
Die Win-Software muss die Datenbank anlegen, daher sollte dies von PostgreSQL auch auf der Sambafreigabe möglich sein, wie stelle ich dies in welcher Datei in PostgreSQL ein?

EDIT:
Damit ich schon einmal mit der Datenübernahme beginnen kann, läuft seit gestern ein kleiner Win8.1-PC mit PostgreSQL 8.4.22.
Wenn PostgreSQL auf dem Linux-PC läuft, können die Daten dann problemlos übernommen werden?


Vielen Dank im Voraus
Viele Grüße
Jürgen

"Kaum macht man es richtig, .... schon geht es!"

akretschmer
Erfahrener Benutzer
Beiträge: 7373
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von akretschmer » Di 2. Dez 2014, 10:41

jogi29 hat geschrieben:
Da ich meine Software wechseln muss (Softwarefirma stellt die Software zum 31.12.2014 ein) muss ich einen Softwarewechsel durchführen und die neue Software benötigt auf dem Server einen PostgreSQL 8.4, neuere Versionen werden nicht unterstützt. Ich habe nun die Pakete 8.4.21 aus Squeeze installiert, was auch funktioniert hat.


8.4 ist seit sooo alt, daß es seit Juli 2014 nicht mehr unterstützt wird. Höhere Versionen sind kompatibel, Du kannst höchstwahrscheinlich auch 9.3 nutzen - oder 9.4 in wenigen Tagen.


In der neuen Win-Software muss ich die IP sowie den Port des PostgreSQL eintragen, damit eine Verbindung hergestellt wird.
1. Problem:
Ich muss das Passtwort des Benutzers "postgres" erst nochmals setzen, bevor eine Verbindung zustande kommt, dann klappt es aber und bei Neustart des Clients ist die Verbindung auch weiter vorhanden. Sollte eigentlich nicht weiter stören, da die Verbindung 1x hergestellt wird und danach nichts mehr geändert wird.

Wo ist jetzt das Problem?

2. Problem:
Die Win-Software muss die Datenbank anlegen, daher sollte dies von PostgreSQL auch auf der Sambafreigabe möglich sein, wie stelle ich dies in welcher Datei in PostgreSQL ein?


Die DB wird NICHT auf einem SAMBA-Share laufen können, das ist aber auch komplett egal. Aus Sicht des Clients ist es völlig schnuppe, wo die Daten liegen.

EDIT:
Damit ich schon einmal mit der Datenübernahme beginnen kann, läuft seit gestern ein kleiner Win8.1-PC mit PostgreSQL 8.4.22.
Wenn PostgreSQL auf dem Linux-PC läuft, können die Daten dann problemlos übernommen werden?


Vielen Dank im Voraus



Ja. Dump & Restore.

jogi29
Neuer Benutzer
Beiträge: 4
Registriert: Di 2. Dez 2014, 09:26
Wohnort: Ländle

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von jogi29 » Di 2. Dez 2014, 11:02

vielen Dank erst einmal für die schnelle Antwort.

Der Softwarehersteller hat mich extra mehrfach darauf hingewiesen, dass nur Version 8.4 unterstützt wird.

zu Problem 1:
eigentlich kein Problem mehr, nur die Frage, wieso das Passwort "vergessen wird, ob da etwas bekannt ist.

zu Problem 2:
die Datenbank lässt sich durch die Software aber nicht erstellen, das ist ja das Problem, könnte wohl ein Rechteproblem sein.
Ich habe für den User "postgres" ein Passwort gesetzt und mit diesem User wird auch die Verbindung zu PostgreSQL hergestellt, aber die Datenbank lässt sich leider nicht erstellen.
Viele Grüße
Jürgen

"Kaum macht man es richtig, .... schon geht es!"

akretschmer
Erfahrener Benutzer
Beiträge: 7373
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von akretschmer » Di 2. Dez 2014, 11:32

jogi29 hat geschrieben:vielen Dank erst einmal für die schnelle Antwort.

Der Softwarehersteller hat mich extra mehrfach darauf hingewiesen, dass nur Version 8.4 unterstützt wird.


Das halte ich für Bullshit. Weise den Hersteller bitte daraf hin, daß es für 8.4 keine Sicherheitsupdates mehr gibt.

zu Problem 1:
eigentlich kein Problem mehr, nur die Frage, wieso das Passwort "vergessen wird, ob da etwas bekannt ist.


Das Passwort muß sich ja der Client merken, also Deine Anwendung. Frag also den Hersteller.

zu Problem 2:
die Datenbank lässt sich durch die Software aber nicht erstellen, das ist ja das Problem, könnte wohl ein Rechteproblem sein.
Ich habe für den User "postgres" ein Passwort gesetzt und mit diesem User wird auch die Verbindung zu PostgreSQL hergestellt, aber die Datenbank lässt sich leider nicht erstellen.


Fehlermeldungen? Am besten die von PG-Seite aus.

jogi29
Neuer Benutzer
Beiträge: 4
Registriert: Di 2. Dez 2014, 09:26
Wohnort: Ländle

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von jogi29 » Di 2. Dez 2014, 16:00

ich bekomme von der Win-Software nur eine nichtssagende Meldung, dass die Datenbankl nicht erstellt werden konnte.

Wie kann ich die bei PostgreSQL loggen, damit man eine entsprechende Meldung bekommt?
Viele Grüße
Jürgen

"Kaum macht man es richtig, .... schon geht es!"

akretschmer
Erfahrener Benutzer
Beiträge: 7373
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von akretschmer » Di 2. Dez 2014, 16:05

jogi29 hat geschrieben:ich bekomme von der Win-Software nur eine nichtssagende Meldung, dass die Datenbankl nicht erstellt werden konnte.

Wie kann ich die bei PostgreSQL loggen, damit man eine entsprechende Meldung bekommt?


In der postgresql.conf sind entsprechende Optionen.

jogi29
Neuer Benutzer
Beiträge: 4
Registriert: Di 2. Dez 2014, 09:26
Wohnort: Ländle

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von jogi29 » Di 2. Dez 2014, 18:40

Code: Alles auswählen

2014-12-02 18:31:20 CET FATAL:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET FATAL:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET ERROR:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET STATEMENT:  REVOKE ALL ON DATABASE zentraldb FROM PUBLIC;
   GRANT CONNECT ON DATABASE zentraldb TO hmdusers;
2014-12-02 18:31:27 CET FATAL:  database "zentraldb" does not exist


Die Windowsanwendung bringt den Fehler

Code: Alles auswählen

Berechtigungen auf die Datenbank konnten nicht angepasst werden


Die Datenbank "zentraldb" soll durch die Windowsanwendung angelegt werden, was beim PostgreSQL für Windows auch funktioniert.
Viele Grüße
Jürgen

"Kaum macht man es richtig, .... schon geht es!"

akretschmer
Erfahrener Benutzer
Beiträge: 7373
Registriert: So 29. Okt 2006, 13:35
Wohnort: Kaufbach, Sachsen, Germany, Germany
Kontaktdaten:

Re: PostgreSQL 8.4 auf Debian Wheezy

Beitrag von akretschmer » Di 2. Dez 2014, 19:10

jogi29 hat geschrieben:

Code: Alles auswählen

2014-12-02 18:31:20 CET FATAL:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET FATAL:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET ERROR:  database "zentraldb" does not exist
2014-12-02 18:31:24 CET STATEMENT:  REVOKE ALL ON DATABASE zentraldb FROM PUBLIC;
   GRANT CONNECT ON DATABASE zentraldb TO hmdusers;
2014-12-02 18:31:27 CET FATAL:  database "zentraldb" does not exist


Die Windowsanwendung bringt den Fehler

Code: Alles auswählen

Berechtigungen auf die Datenbank konnten nicht angepasst werden


Die Datenbank "zentraldb" soll durch die Windowsanwendung angelegt werden, was beim PostgreSQL für Windows auch funktioniert.



Was an "2014-12-02 18:31:27 CET FATAL: database "zentraldb" does not exist" genau hast Du jetzt nicht verstanden?

Es gibt den Befehl 'createdb', ich denke mal, das ist Dein Freund.

Antworten