Installation PostgreSQL 9.1.3 macht große Probleme

Fragen und Probleme zur Installation von PostgreSQL (hauptsächlich Binary Packete).
Antworten
DEMO
Neuer Benutzer
Beiträge: 3
Registriert: Do 10. Jul 2014, 13:46

Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von DEMO » Do 10. Jul 2014, 14:25

Hallo liebes Forum,

ich habe sehr große Probleme bei der Installation von PostgreSQL 9.1.3 / PostGIS 2.0.3 (habe ich mir bei ESRI
heruntergeladen)
Vielleicht könnt ihr mir helfen.
Als Betriebssysytem läuft Windows 7 (SP1) 64Bit und ArcGIS 10.1 (SP1) for Desktop ist installiert.

Es passiert folgendes:

Ich starte die Installationsdatei "PostgreSQL_DBMS_for_Windows_913_136059.exe" und folge dem Setup Wizard
bis die Installation beginnt. Diese verläuft auch fast bis zum Schluss unproblematisch. Ganz am Ende kommt dann
aber eine Fehlermeldung, dass der "Uninstaller" nicht mitinstalliert werden konnte. Drückt man nun auf "Finish", so
wird der Installationsprozess korrekt beendet und man kann den "Stack Builder" starten. Ich wähle nun bei den
"Spatial Extensions" meine PostGIS-Erweiterung aus und aktiviere "Create spatial database".
Beim nächsten Schritt muss ich den Zielpfad angeben und hier geht es dann nicht mehr weiter. Ich kann kein
"Destination Folder" angeben und muss die Installation abbrechen.
Und jetzt das eigentlich Schlimme: ich kann nicht mehr auf mein lokales Laufwerk C: zugreifen!!! Ich habe dann
das Image meiner Festplatte neu aufgespielt und die Installation erneut ausgeführt - mit genau dem gleichen Ergebnis!!!

Hat einer von euch eine Erklärung, einen Ratschlag?

Vielen Dank im voraus und Grüße,

DEMO

castorp
Erfahrener Benutzer
Beiträge: 1023
Registriert: Sa 27. Jun 2009, 22:24

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von castorp » Do 10. Jul 2014, 14:31

DEMO hat geschrieben:Ich starte die Installationsdatei "PostgreSQL_DBMS_for_Windows_913_136059.exe"
Das ist kein offizieller Installer.

Und jetzt das eigentlich Schlimme: ich kann nicht mehr auf mein lokales Laufwerk C: zugreifen!
Klingt danach als hätte dieser dubiose Installer einen Virus enthalten.
Bitte verwende den offiziellen Installer von hier: http://www.enterprisedb.com/products-se ... pgdownload

Und wenn Du schon eine veraltete Version nehmen willst (aktuell ist 9.4.x) dann nimm wenigstens die neueste aus dem Branch. Aktuelle Version der 9.1 ist 9.1.13, nicht 9.1.3
A SQL query walks into a bar and sees two tables. He walks up to them and says 'Can I join you?'

DEMO
Neuer Benutzer
Beiträge: 3
Registriert: Do 10. Jul 2014, 13:46

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von DEMO » Do 10. Jul 2014, 14:39

Danke castorp für die schnelle Antwort.

Der Online-Support von ESRI schlägt eben 9.1.3 vor. Weißt Du denn,
ob ich die aktuellste PostgreSQL/PostGIS-Version 9.4.x in Verbindung
mit ArcGIS 10.1 (SP1) verwenden kann?

castorp
Erfahrener Benutzer
Beiträge: 1023
Registriert: Sa 27. Jun 2009, 22:24

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von castorp » Do 10. Jul 2014, 14:56

DEMO hat geschrieben:Der Online-Support von ESRI schlägt eben 9.1.3 vor.
Wenn die sich sicher sind, die Performance, Stabilitäts und Sicherheits - Fixes von 2 Jahren nicht zu benötigen, dann werden sie schon wissen warum.

Weißt Du denn, ob ich die aktuellste PostgreSQL/PostGIS-Version 9.4.x in Verbindung
mit ArcGIS 10.1 (SP1) verwenden kann?
Keine Ahnung
(ich habe mich übrigens vertippt: aktuell ist 9.3, die 9.4 ist erst im Beta).
A SQL query walks into a bar and sees two tables. He walks up to them and says 'Can I join you?'

Gisman
Erfahrener Benutzer
Beiträge: 1093
Registriert: Fr 20. Jan 2006, 15:30
Wohnort: Pfalz
Kontaktdaten:

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von Gisman » Fr 11. Jul 2014, 15:32

Die aktuelle PG-Version geht in der Tat nicht. ArcGIS geht nur mit 9.1 (ArcGIS 10.1) oder 9.2 (ArcGIS 10.2) warum auch immer. Ich habe eine handelsübliche 9.2 selbstkompiliert mit PostGIS 2.0. Was du allerdings dazu brauchst sind die Client-Libs, die es bei ESRI zum Download gibt. Ich würde es an deiner Stelle auch so machen (also mit einer Standard-Windowsversion falls kein Linux zur Hand ist) dann bekommst du hier auch eher Hilfe. Was ESRI da zusammenbastelt weiß keiner so recht, und Support leisten die IMHO auch nicht so wirklich dafür.

Gruß Uwe

DEMO
Neuer Benutzer
Beiträge: 3
Registriert: Do 10. Jul 2014, 13:46

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von DEMO » So 13. Jul 2014, 12:49

Hi Uwe,

danke für die Meldung. Ich habe jetzt die 9.1.13 mit den dazugehörigen Client-Libs installiert
und bisher funktioniert auch alles.
Aber trotzdem brutal, dass solche schwerwiegenden Probleme auftreten können. Wenn ich
kein aktuelles Image von C: gehabt hätte, wäre ich ganz schön angeschmiert gewesen.
Nicht einmal bei ESRI sind die Downloads ok... schade!

Grüßle, Markus

Gisman
Erfahrener Benutzer
Beiträge: 1093
Registriert: Fr 20. Jan 2006, 15:30
Wohnort: Pfalz
Kontaktdaten:

Re: Installation PostgreSQL 9.1.3 macht große Probleme

Beitrag von Gisman » So 13. Jul 2014, 18:53

DEMO hat geschrieben:Nicht einmal bei ESRI sind die Downloads ok... schade!


Ich könnte dir da Dinge von ESRI erzählen, da rollen sich dir die Zehennägel auf ;)

Grüßle Uwe

Antworten