postgres, passwd bringt nichts

Hi, und zwar versuche ich gerade postgreSQL auf meinem ubuntu-server einzurichten. Installiert hab ich es soweit erfolgreich, server läuft. Via “sudo passwd mypsd” hab ich ebenfalls das Passwort geänder. Nur wenn ich damit auf die DB zugreifen will, funktioniert das nicht (password failed).

Muss ich das Password für den Unix-User postgres erst auf die Datenbank übertragen? Und wie könnte das aussehen?

System-User != DB-User.

Andreas

… jep war mir klar. Nur wie kann ich das db-password vom postgres user ändern?



test=# \h alter user
Command:     ALTER USER
Description: change a database role
Syntax:
ALTER USER name [ [ WITH ] option [ ... ] ]

where option can be:

      SUPERUSER | NOSUPERUSER
    | CREATEDB | NOCREATEDB
    | CREATEROLE | NOCREATEROLE
    | CREATEUSER | NOCREATEUSER
    | INHERIT | NOINHERIT
    | LOGIN | NOLOGIN
    | CONNECTION LIMIT connlimit
    | [ ENCRYPTED | UNENCRYPTED ] PASSWORD 'password'
    | VALID UNTIL 'timestamp'

ALTER USER name RENAME TO newname

ALTER USER name SET parameter { TO | = } { value | DEFAULT }
ALTER USER name RESET parameter

test=#

Andreas

Okay sieht ganz vernünftig aus. Nur… ich kann mit mit psql nicht zur db verbinden, da ich das passwort nicht kenne? :confused:

Okay super sache, hat wunderbar alles funktionier:

sudo su postgres -c psql template1

damit war ich beim promt des pgsql-servers und habe da eingegeben

ALTER USER postgres WITH PASSWORD 'meintollespasswort';

Danke! :slight_smile: