PG 8.1 initdb: child process was terminated by signal 11

Nach der Installation von PostgreSQl 8.1 auf AIX 5.1 bricht initdb mit folgender Meldung ab:

$ initdb -d
Running in debug mode.
VERSION=8.1.0
PGDATA=/database/data
share_path=/usr/local/pgsql/share
PGPATH=/usr/local/pgsql/bin
POSTGRES_SUPERUSERNAME=postgres
POSTGRES_BKI=/usr/local/pgsql/share/postgres.bki
POSTGRES_DESCR=/usr/local/pgsql/share/postgres.description
POSTGRESQL_CONF_SAMPLE=/usr/local/pgsql/share/postgresql.conf.sample
PG_HBA_SAMPLE=/usr/local/pgsql/share/pg_hba.conf.sample
PG_IDENT_SAMPLE=/usr/local/pgsql/share/pg_ident.conf.sample
The files belonging to this database system will be owned by user “postgres”.
This user must also own the server process.

The database cluster will be initialized with locale en_US.
The default database encoding has accordingly been set to LATIN1.

fixing permissions on existing directory /database/data … ok
creating directory /database/data/global … ok
creating directory /database/data/pg_xlog … ok
creating directory /database/data/pg_xlog/archive_status … ok
creating directory /database/data/pg_clog … ok
creating directory /database/data/pg_subtrans … ok
creating directory /database/data/pg_twophase … ok
creating directory /database/data/pg_multixact/members … ok
creating directory /database/data/pg_multixact/offsets … ok
creating directory /database/data/base … ok
creating directory /database/data/base/1 … ok
creating directory /database/data/pg_tblspc … ok
selecting default max_connections … 10
selecting default shared_buffers … 50
creating configuration files … ok
creating template1 database in /database/data/base/1 … DEBUG: invoking IpcMemoryCreate(size=1335296)
LOG: database system was shut down at 2005-12-01 08:40:47 NFT
LOG: checkpoint record is at 0/20
LOG: redo record is at 0/20; undo record is at 0/20; shutdown TRUE
LOG: next transaction ID: 3; next OID: 10000
LOG: next MultiXactId: 1; next MultiXactOffset: 0
LOG: database system is ready
child process was terminated by signal 11
initdb: removing contents of data directory “/database/data”
$

buuh, auf anhieb wüsst ich jetzt hier auch nichts. was steht in deiner logdatei drinnen oder kommt er gar nicht so weit?

steht in einen anderen log was? ich kenn mich mit aix nicht aus und weiß nicht was hier für logs existieren. bei linux würd ich mal dmesg prüfen und messages und syslog. evtl beißt sich da was…

cu tb.

moin,

hab nochmal ein bisschen rumgesucht. der “signal 11” fehler tritt meistens bei fehlerhaften bibliotheken auf. hast du postgres als binary installiert oder selbst kompiliert?

es gibt auch in den sourcen unter /doc eine FAQ_AIX datei. hier werden auch div. probleme von postgresql auf aix beim kopmilieren beschrieben und stehen auch lösungen. evtl hast du hier einfach ein problem.

wie gesagt habe ich kein aix hier umd das einfach mal zu testen…

cu tb.