keine Berichte (reports) nach Umzug möglich

Die letzten Tage hatte ich einen sehr alten Datenbankcluster auf ein Neusystem migriert (Pentium III mit weniger als 1 GB und Debian 4 und pgsql 7.1 —> Intel i2 mit 4 GB und Debian 9 und pgsql 9.4), wobei nicht alles glatt lief. Die Qualität (Konsistenz und Vollständigkeit) der übernommen Daten ist zweifelhaft; aber ich kann von meinem Arbeitsplatzrechner (mit Xubuntu 16.04) schon wieder mittels pgAdmin III und mit PHPpgadmin darauf zugreifen.

Letzteres macht allerdings noch Zicken, weil es keine Berichte mehr erstellen und anzeigen kann. Darin wären aber Prüfabfragen gewesen, welche mir bei der Bewertung der Lage helfen würden.

Die Einzeldatenbank phppgadmin wurde beim Übernehmen anscheinend vollzählig wiederhergestellt; die Tabelle ppa_reports enthielt und enthält immer noch 37 Zeilen mit plausiblem Inhalt. Leider bleiben diese aber alle unsichtbar und auch die Schaltfläche für Berichte ist nirgends zu sehen. Die Suchmaschine meines Vertrauens riet mir, in der Datei config.inc.php folgende Zeilen zu ergänzen:

// Display reports feature? For this feature to work, you must
// install the reports database as explained in the INSTALL file.
  $conf['show_reports'] = true;
// Database and table for reports
  $conf['reports_db'] = 'phppgadmin';
  $conf['reports_schema'] = 'public';
  $conf['reports_table'] = 'ppa_reports';

Das habe ich getan, aber es zeigt keine Wirkung. Woran könnte es sonst noch liegen?

Was mich dabei noch irritiert hat: daß die Musterdatei, so wie ich sie nach frischer Installation von phppgadmin vorfand, diesen Parameter überhaupt nicht enthielt.
Bildschirmfoto_2018-05-20_14-18-22.png
Bildschirmfoto_2018-05-20_14-18-12.png

ich kenne und nutze PhpPgAdmin nicht. Was sind das für “Berichte”, die Du jetzt nicht findest?

Das sind SQL-Abfragen auf den Datenbanken, welche ich früher (bis zur Zwangspause ab 2016) erstellt hatte. Beim Umzug sind sie mitgenommen worden.

Von der Menge her (37 Stück) könnte ich sie neu erzeugen (die alten Eingaben sind richtig übernommen worden und außerdem kann ich den fast kaputten alten Rechner noch immer parallel betreiben). Es wären nur etliche Kopiervorgänge per Zwischenablage von einem Browserfenster in ein anderes; also durchaus zumutbar. Leider aber fehlt in der Benutzeroberfläche auf dem neuen System jeglicher Zugang zu den Berichten, so daß ich nicht einmal welche erzeugen kann. Auf dem Bildschirmabzug vom Altsystem habe ich die entsprechende Stelle rot eingekringelt.

Hier beschreibt ein anderer Nutzer seine Schwierigkeiten: https://stackoverflow.com/questions/8894/use-for-the-phppgadmin-reports-database, bei mir dagegen hat es auf dem Altsystem jahrelang störungsfrei funktioniert und hat mir großen Komfort beim Arbeiten geboten. So ist die entscheidende Funktion beschrieben, welche jetzt fehlt:

PhpPgAdmin has functionality to browse and execute these reports. It’s a pretty simple system just meant to aid in organization.

Daran, daß es extra eingerichtet werden mußte, kann ich mich gar nicht mehr erinnern. Hier ist die Beschreibung für Debian: https://wiki.debian.org/PhpPgAdmin; sollte aber alles erledigt sein, weil ich direkt aus dem Debian-Repository installiert habe.

Was ich → hier lese (ganz am Schluß) ←, verwirrt mich sehr stark, weil die entsprechenden Einstellungen nicht in meiner vorgegebenen Konfigurationsdatei enthalten sind. Da werde ich nochmal drüber schlafen.

Diese Anleitung hat teilweise geholfen: https://github.com/phppgadmin/phppgadmin/blob/master/plugins/Report/INSTALL.
Das hat gefehlt: $conf[‘plugins’] = array(‘Report’);
Die Reportsfunktion erscheint jetzt, wirft aber noch Fehler aus, die ich hoffentlich selber aufklären kann:

SQL-Fehler:
FEHLER:  Spalte »paginate« existiert nicht
LINE 1: ...,"date_created","created_by","descr","report_sql","paginate"...
                                                             ^
In der Anweisung:
SELECT "report_id","report_name","db_name","date_created","created_by","descr","report_sql","paginate" FROM "ppa_reports" ORDER BY "db_name", "report_name"

Des Rätsels (wieder nur teilweise) Lösung: gegenüber der alten Version ist eine Spalte dazugekommen in der Tabelle ppa_reports.

paginate boolean NOT NULL,

Diese Spalte habe ich einfach hinzugefügt und mit FALSCH vorbesetzt für alle; und schon funktioniert es!

Was allerdings nicht funktioniert: den Seitenumbruch nachträglich einschalten; es gibt wieder Fehlermeldungen. Die erste Seite wird ausgegeben, aber beim Weiterblättern auf die zweite Seite oder eine andere beliebige Folgeseite wird could not find the query!! gemeldet und die ganze Ergebnisliste wird unpaginiert ausgegeben. Erzeuge ich den Bericht dagegen neu und speichere gleich mit Seitenumbruch ab, schaut die Fehlermeldung so aus und nichts weiter wird ausgegeben:

Error: plugin '' not found. Check if this plugin exists in the plugins/ directory, or if this plugins has a plugin.php file. Plugin's names are case sensitive

Damit kann ich aber leben.