Installationsprobleme Prozessanlage für initdb scheiterte

Hallo!

Kann mir jemand bitte weiterhelfen. Verzweifle fast. Jedes mal wenn ich Postgre SQL 8.1. installiere kommt bei der Initialisierung des Datenbank Clusters folgende Fehlermeldung: Prozessanlage für initdb scheiterte: Zugriff verweigert.

Kann mir jemand bei dem Problem helfen?

Tolle Sache … was sollen wir mit der Fehlermeldung anfangen?

Welches OS oder welche Windows Version nutzt du?
Wenn du ein Unix/Linux benutzt, warum nimmst du nicht ein fertiges Paket?

Bin ein Neuling!
Nutze Windows 2000

Du installierst das als Administrator?

ja

Hmm, in dem Fall verlassen mich meine Kentnisse für Windows …
Tut mir leid.

Vielleicht kann einer der Windows User hier im Forum da weiterhelfen.

dank dir trotzdem

Hallo!

Das Problem besteht immer noch! Hier ist die genaue Fehlermeldzung aus der LOG. Kann mir jamand da weiterhelfen bitte?

Aktion 15:24:42: RunInitdb. Initialisiere den Datenbank-Cluster (das kann schon ein bis zwei Minuten dauern)
MSI (s) (EC:38) [15:24:42:964]: Executing op: CustomActionSchedule(Action=RunInitdb,ActionType=1025,Source=BinaryData,Target=RunInitdb@4,CustomActionData=1031;
C:\Programme\PostgreSQL\8.1;C:\Programme\PostgreSQL\8.1\data;C:\Programme\PostgreSQL\8.1\share;5432;;C;SQL_ASCII;postgres;postgres;
GIRIBESVLAKTE;postgres2;postgres :wink:
MSI (s) (EC:04) [15:24:42:994]: Invoking remote custom action. DLL: C:\WINNT\Installer\MSI129.tmp, Entrypoint: RunInitdb@4
MSI © (28:40) [15:24:43:645]: Note: 1: 2205 2: 3: Error
MSI © (28:40) [15:24:43:645]: Note: 1: 2228 2: 3: Error 4: SELECT Message FROM Error WHERE Error = 2867
DEBUG: Error 2867: The error dialog property is not set
Bei der Installation dieses Pakets ist ein unerwarteter Fehler aufgetreten. Es liegt eventuell ein das Paket betreffendes Problem vor. Der Fehlercode ist 2867. Argumente: , ,
MSI © (28:40) [15:24:43:655]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

Prozessanlage für initdb scheiterte: Zugriff verweigert

MSI (s) (EC!48) [15:25:07:599]: Note: 1: 2205 2: 3: Error
MSI (s) (EC!48) [15:25:07:599]: Note: 1: 2228 2: 3: Error 4: SELECT Message FROM Error WHERE Error = 1709
MSI (s) (EC!48) [15:25:07:599]: Produkt: PostgreSQL 8.1 – Prozessanlage für initdb scheiterte: Zugriff verweigert

hallo,

bist du der benutzer “Administrator” oder nur irgendein benutzer mit administratoren rechte? wenn zweites dann log dich direkt als administrator ein.

schau auch mal ob du alle updates eingespielt hast. für den msi installer unter win 2k gab es mal ein update wenn ich mich richtig erinnere.

cu tb.

Hallo !

Also ich bin als Admin angemeldet und habe mir die neuesten Updates auf den Rechner installiert. Die Fehlermeldung besteht aber immer noch. So langsam verzweifel ich !

Hallo,

die Meldung

MSI © (28:40) [15:24:43:645]: Note: 1: 2205 2: 3: Error

besagt, dass die Datenbanktabellen nicht installiert werden konnten, was mit dem Befehl erfolgt:

MSI (s) (EC:04) [15:24:42:994]: Invoking remote custom action. DLL: C:\WINNT\Installer\MSI129.tmp, Entrypoint: RunInitdb@4

Und diese Meldung beschreibt doch eindeutig die Ursache

Prozessanlage für initdb scheiterte: > Zugriff verweigert

d.h. MSI kann initdb nicht ausführen weil der User keine Zugriffsrechte darauf hat.

Wichtig ist das Dein User Admin auch alle Superuser-Rechte hat. Bekannt ist aber auch, dass einige Virenprogramme MSI blockieren. Wenn ein Virenprogramm installiert ist, solltest Du es vorübergehend mal deinstallieren. Vielleicht hilft es weiter.


mfg

fristo

Hallo!

Also, habe mein Antivirusprogramm (Norten) deaktiviert. Auch weiterhin erscheint die Fehlermeldung! Ich glaube jedoch es liegt am meinem Administrator. Also, mein Rechner hat einen Namen und es gibt eine Arbeitsgruppe. Liegt es vielleicht daran das ich den Namen der Arbeitsgruppe bei der Installierung angeben muss. Dies habe ich auch schon probiert, jedoch kam der Fehler der Benutzer konnte im System nicht angemeldet werden. Was nun ?

hi,

die arbeitsgruppe musst du doch beim login nicht mit angeben!? las das einfach weg. das ist doch nur interessant wenn du eine domäne hast…

cu tb

Hallo,

das stimmt. Daran kann es auch nicht liegen. Woran kann es denn noch liegen? Welche Zusatzprogramme oder Skripte müssen denn auf dem Rechner sein. Vielleicht liegt es ja daran?

Gruß
PascalPaoli

aus falschen thread hier eingefügt…

cu tb.