Installationsprobleme: Benutzung von PostGIS Geometrien wirft Fehler.

Hallo zusammnen,

ich möchte PostGIS installieren.

Installiert teilweise auf meinem System vom Ubuntu Installationsmanager. Aber wie ich in der Doku
PostGIS 1.3.5 Manual gelesen habe sind noch einige Schritte notwendig, um PostGIS auch in meiner DB nutzen zu können. Diese habe ich ausgeführt, aber scheinbar scheint das nicht funktioniert zu haben, das hier geben die im Tutorial ausgeführten Befehle zurück

SELECT AddGeometryColumn(’’, ’gtest’,’geom’,-1,’LINESTRING’,2);
bash: syntax error near unexpected token `(

INSERT INTO gtest (ID, NAME, GEOM)VALUES (  1,  ’First Geometry’,  GeomFromText(’LINESTRING(2 3,4 5,6 5,7 8)’, -1));
FEHLER:  Syntaxfehler bei »Geometry’«
LINE 1: ...T INTO gtest (ID, NAME, GEOM)VALUES (  1,  ’First Geometry’,...

Ich habe unten mal meine Installation aufgeschrieben. Habe ich die Befehle falsch meinem System angepasst? Kann mir jemand sagen wo ich einen Fehler gemacht habe?

Bin für jede Hilfe dankbar,
mxm

Folgende Schritte habe ich während der Installation ausgeführt. Da ich die entsprechenden Dateien aufgrund der automatischen Ubuntu Installation bereits auf dem System hatte, habe ich erst bei Schritt sieben angefangen, laut Manuals ist hier zu tun:

   
  createlang plpgsql [yourdatabase]

Bei mir hieß das:

 createlang plpgsql postgres
  1. laut Manuals
 # psql -d [yourdatabase] -f lwpostgis.sql

Bei mir:

psql postgres -f /usr/share/postgres-8.3-postgis/lwpostgis.sql
  1. laut Manuals:
  #psql -d [yourdatabase] -f spatial_ref_sys.sql
  1. Bei mir:
    # psql  postgres -f  /usr/share/postgres-8.3-postgis/spatial_ref_sys.sql

postgis comments.sql konnte ich nicht installieren, da ich es nicht in dem Ordnert liegen hatte.

Dann habe ich noch das Soft-Upgrade ausgeführt

 psql postgres -f /usr/share/postgresql-8.3-lwpostgis_upgrade.sql

Das wars, hat jemand eine Idee woran es liegen könnte.

Hallo

Meine erste Vermutung:

Du schreibst:

SELECT AddGeometryColumn(’’, ’gtest’,’geom’,-1,’LINESTRING’,2);

Versuch mal bitte:

SELECT AddGeometryColumn(’gtest’,’geom’,-1,’LINESTRING’,2);

Bin mir nicht sicher, könnte aber an dem leeren Feld liegen.

Nun ja, meine bash versteht auch kein SQL.

Andreas

Da du keine Fehler bei der Installation vermeldest, scheint da alles glatt gelaufen zu sein.

Du kannst ein SQL Statement über die bash mit psql absetzen, direkt geht das nicht.
Bei deinem Insert-Statement fehlt übrigens eine schliessende Klammer (wenn ich ohne Kaffee schon richtig bis 4 zählen kann :wink: ), was die darauffolgende Fehlermeldung erklärt…

Grüssle Uwe