Grant/Revoke etc. funktioniert über PGADMIN II nicht

Hallo zusammen,

ich wollte gerade mal ein paar Benutzer und Gruppen einrichten und dachte, ich mach das über PGADMIN III (ja, das ist Windows, ich weiss - die Datenbank (8.1) läuft auch über Windows!).

Leider musste ich feststellen, dass dies über PGADMIN bei mir nicht funktioniert. Die SQL-Statements, die erzeugt werden, sind richtig, aber sie scheinen keinerlei Effekt zu haben. Das geht soweit, dass ein Grant-Statement über das Abfragetool von PGADMIN ausgeführt zwar keinerlei Fehlermeldung erzeugt, aber schlichtweg keinerlei Auswirkungen hat. Das gleiche Statement über psql ausgeführt funktioniert wunderbar!!! Angemeldet bin ich bei PGADMIN logischerweise mit dem Superuser.

Weiss jemand Rat? Ich mache das Ganze jetzt zwar über psql, weils da funktioniert - aber auf Dauer ist das leider keine Lösung, da auch Kollegen ohne meine Hilfe administrieren können müssen, ohne dass sie Kenntnisse in SQL etc. haben, sondern eben mittels eines Tools.

Grüße,
Bierstuebl

Seufz.

Leider musste ich feststellen, dass dies über PGADMIN bei mir nicht funktioniert. Die SQL-Statements, die erzeugt werden, sind richtig, aber sie scheinen keinerlei Effekt zu haben. Das geht soweit, dass ein Grant-Statement über das Abfragetool von PGADMIN ausgeführt zwar keinerlei Fehlermeldung erzeugt, aber schlichtweg keinerlei Auswirkungen hat. Das gleiche Statement über psql ausgeführt funktioniert wunderbar!!! Angemeldet bin ich bei PGADMIN logischerweise mit dem Superuser.

Wilde Vermutung: Du arbeitest in einer Transaktion und hast das COMMIT vergessen. Bzw. Dein Klick-Tool.

Weiss jemand Rat? Ich mache das Ganze jetzt zwar über psql, weils da funktioniert - aber auf Dauer ist das leider keine Lösung, da auch Kollegen ohne meine Hilfe administrieren können müssen, ohne dass sie Kenntnisse in SQL etc. haben, sondern eben mittels eines Tools.

Falls meine Vermutung nicht stimmt:

Logge das, was von dem Tool an den Server geschickt wird. Vielleicht fehlt da was, vielleicht ist ein Bugreport nötig. Aber, wie gesagt, logge am Server mal alle Statements und schau, was da passiert.


Andreas

Hallo Andreas,

schnell wie immer :slight_smile:

Mit deiner Vermutung liegts du leider falsch. Keine Transaktion und das Tool vergisst auch kein Commit. Das Abfragetool von PGADMIN dient nur dazu, SQL-Statements auszuführen. Ein Insert beispielsweise funktioniert wunderbar - ohne commit in einer Transaktion wäre es dann ja nicht möglich, die Änderung in anderen Prozessen zu sehen, gelle. Soweit ich das sehe benutzt PGADMIN ODBC, evtl. könnte das ein Problem verursachen.

Mitloggen mache ich, wenn das Problem richtig akut wird, im Moment reicht die Zeit nicht, bin hier unter Wasser.

Trotzdem Danke,
Bierstuebl

Mal ganz blöd: Hast du die Ansicht immer schön aktualisiert? pgAdmin macht das nicht von allein :wink: , bin da auch schon drauf reingefallen…

Das gibts übrigens auch für Linux, also keine Ausreden… :wink:

Frage: Wie postet man unter Wasser? :confused: :astonished: :wink:

Gruß Uwe

Hmm, größenteils Entwarnung. Teilweise wars Deppertheit von mir :sunglasses:

Was über PGADMIN irgendwie nicht funktioniert hat, war das Verbinden einer Login-Rolle zu einer Rolle (für Leute wie mich: das Hinzufügen eines Users zu einer Gruppe). Die Rechte waren zwar auf die Tables vergeben, aber der Benutzer wurde ums verrecken nicht der Gruppe hinzugefügt. Nachdem ich das jetzt per psql gemacht hab, funktioniert auch die Rechtevergabe über PGADMIN.

Frage: Wie postet man unter Wasser?

Antwort: Jahrelanges Training und eiserne Disziplin sowie ein unbändiger Wille und…

Grüße,
Bierstuebl