Datensatz wird nicht gefunden, obwohl er da ist

Hallo,

ich habe ein etwas seltsames Problem.

In meiner Datenbank habe ich eine Tabelle angelegt mit Städtenamen. Die Tabelle ist mit den größten Städtenamen gefüllt.

Nun erstelle ich eine Abfrage nach einem Stadtnamen (z.B. Hamburg):
SELECT “name” FROM “public”.“ki_conc_city” WHERE “name” = ‘Hamburg’

Dabei wird kein Datensatz gefunden.

Wenn ich aber mir die Einträge mit phppgadmin ansehe, dann ist da eindeutig ein Eintrag ‘Hamburg’

Eine Suche über die ID funktioniert auch:

SELECT “name” FROM “public”.“ki_conc_city” WHERE “id” = 2

Woran kann es liegen, dass er für den Namen keine Einträge findet??

Sicher, daß in der DB ‘Hamburg’ steht und nicht vielleicht 'Hamburg '?

test=# create table stadt (id int, name text);
CREATE TABLE
Time: 669.913 ms
test=*# copy stadt from stdin;
Enter data to be copied followed by a newline.
End with a backslash and a period on a line by itself.
>> 1    Hamburg
>> 2    Hamburg
>> \.
test=*# select * from stadt where name='Hamburg';
 id |  name
----+---------
  1 | Hamburg
(1 row)

Time: 57.189 ms
test=*# select * from stadt where name~'Hamburg';
 id |   name
----+----------
  1 | Hamburg
  2 | Hamburg
(2 rows)

test=*# select id, 'x' || name || 'x' from stadt ;
 id |  ?column?
----+------------
  1 | xHamburgx
  2 | xHamburg x
(2 rows)

Andreas

Danke… das war es!

Das muss wohl beim Import der MySQL Daten passiert sein …

seufz

Und welchen Datentyp hat deine aktuelle Spalte und welcher Datentyp war das in MySQL?