Abfrage von DB mit PHP - Lauf gegen die Wand

Moin moin!

Wollte testweise mal ne Abfrage mit php starten. Connecten kann ich auch. Leider findet er das mit PG-Admin angelegte Schema nicht.
Hier der PHP-Code:
[php]<?php

$dbconn = pg_connect(“host=xxx.xxx.xxx.xxx dbname=‘db’ user=dbnutzer password=nutzerpwd”)
or die('Verbindungsaufbau fehlgeschlagen: ’ . pg_last_error());

$query = 'SELECT * FROM schema.benutzer ';
$result = pg_query($query) or die('Abfrage fehlgeschlagen: ’ . pg_last_error());

echo “

\n”;
while ($line = pg_fetch_array($result, null, PGSQL_ASSOC)) {
echo “\t\n”;
foreach ($line as $col_value) {
echo “\t\t\n”;
}
echo “\t\n”;
}
echo “
$col_value
\n”;

pg_free_result($result);

pg_close($dbconn);
?> [/php]

Leider finden wir die Fehlermeldung nicht.

Andreas

Ohhhh Pardon!
Das kommt davon wenn einem im Büro der Kaffee ausgeht… :astonished: :p


Warning> : pg_query() [> function.pg-query> ]: Query failed: ERROR: schema “schema” does not exist in > /usr/local/www/apache22/data/Test.php > on line > 8
Abfrage fehlgeschlagen: ERROR: schema “schema” does not exist

beim nächstenmal hole ich erst Kaffee…Kopfschüttel

Tja. Vermutlich existiert es nicht. Hint: wenn Du PGAdmin verwendest, dann verwendest dieses beim Anlegen neuer Objekte " um die Namen herum. Daher ist dann schon die Schreibweise mit gRoßBuChStAbEn und so wichtig.

Also: starte psql und schaue nach, welche Schemas es wirklich gibt. Hint: \dn

Andreas

Hing mit der schreibweise zusammen.

Statt : schema.benutzer “schema”.“benutzer”

Damit hat es gepasst. Danke für die Hilfe!!